Jump to content

Poe Dameron & Finn


Recommended Posts

Small update 14/02/2016:

 

Just made small small adjustments to the helmet and face, and I darkened the material on the straps a bit:

 

 

4BFCFO.png

 

 

 

Reduce the strength of the AO , some of the wrinkles are insanely dark - if you have a dirt layer on there that's based on AO turn down the intensity/spread of that dirt

 

also relinking this : https://jkhub.org/topic/6178-aayla-secura/page-4?do=findComment&comment=100818

 

Hey thanks for relinking that. I did lower the AO a bit, however some of the shadows are coming from marmoset's sky light and won't actually be present in the textures/Jedi academy.

 

I'll be rigging the pilot outfit shortly to see how it looks in game, so I'll be doing the baking for jedi academy's textures after that.

 

Edit: Just followed the tutorail to make the pilots torso diffuse for Jedi academy - its a really awesome workflow, really captured the details of the cloth, without blowing it out. Makes me want to go back and redo Aayla and Quinlans textures.

AshuraDX, Langerd, Srethem and 1 other like this
Link to comment

Small update 14/02/2016:

 

Just made small small adjustments to the helmet and face, and I darkened the material on the straps a bit:

 

 

4BFCFO.png

 

 

 

 

Hey thanks for relinking that. I did lower the AO a bit, however some of the shadows are coming from marmoset's sky light and won't actually be present in the textures/Jedi academy.

 

I'll be rigging the pilot outfit shortly to see how it looks in game, so I'll be doing the baking for jedi academy's textures after that.

Holy shiet dude.. 11/10

Link to comment

Update 21/02/2016:

 

Here's some modview screenshots with the baked diffuse texture for JKA (note the hair and helmet visor have alphas, just obviously can't display them properly in modview):

 

 

lUwSdW.png

 

gABIyN.png

 

 

The way I'm going about this is, there will be a lower poly model for vanilla JKA, to avoid any ghoul2 errors, but I will also include a separate pk3 with a higher poly model as a replacement for people who wish to use it in OpenJK/JKA enhanced or whenever rend2 kicks off.

DarthStiv and Jeff like this
Link to comment

Heads starting to look a lot more like Oscar Isaac. Only other complaint I have is the outfit is a little bright but other then that looks amazing!

 

I increased the AO and saturation a tad.

 

At the moment I'm a bit stuck. My shaders are not working at all on the model, and I am not sure why. Also the lightsaber blade is missing in singleplayer.

 

There's no error message, in the console. 

 

The mesh itself is 5.9k triangles which is below that of Aayla and Quinlan, which I did not have any issues with - so I do not think its anything to do with the model's density.

 

For example a simple shader for the alpha that I have here:

 

 

models/players/st_poe/head_hair

{
    {
        map models/players/st_poe/head_hair
        alphaFunc GE192
        depthWrite
        rgbGen lightingDiffuse
    }
}

 
Does not even work. I've tried multiple different shaders and still nothing.
 
I'm using a 32bit .tga texture with an alpha. The alpha works fine in modview and other programs, so I'm not sure whats going on.
 
Anyone have any idea on what could be causing these issues?
Link to comment

I increased the AO and saturation a tad.

 

At the moment I'm a bit stuck. My shaders are not working at all on the model, and I am not sure why. Also the lightsaber blade is missing in singleplayer.

 

There's no error message, in the console. 

 

The mesh itself is 5.9k triangles which is below that of Aayla and Quinlan, which I did not have any issues with - so I do not think its anything to do with the model's density.

 

For example a simple shader for the alpha that I have here:

 

 

models/players/st_poe/head_hair

{

    {

        map models/players/st_poe/head_hair

        alphaFunc GE192

        depthWrite

        rgbGen lightingDiffuse

    }

}

 

 

Does not even work. I've tried multiple different shaders and still nothing.

 

I'm using a 32bit .tga texture with an alpha. The alpha works fine in modview and other programs, so I'm not sure whats going on.

 

Anyone have any idea on what could be causing these issues?

Too many shaders and you reached the limit? D:

Scerendo likes this
Link to comment

Also maybe try testing the skin without any other "mods" inside your base/japlus folder to be sure it's something wrong with your model. Again it might just be a matter of a missing open/closed bracket that's making the shaders not work. Maybe you're missing a tag if the lightsaber isn't showing? I know it's all basic things but very easy to forget about checking.

Scerendo likes this
Link to comment

Looks SO good! If Battlefront 3 was moddable, I'd suspect you could get some serious results in that engine!

However even with baked maps, I'm confident this will look exceedingly amazing for Jedi Knight.

 

Would be interesting to see this on Sketchfab, since it supports normal and specular maps and so on.

Scerendo likes this
Link to comment

@@Scerendo about the saber blade not shwoing up... from what I remember this had something to do with the model hierarchy, one of Hapslashs models suffered from the same issue

about your shader problem : try the model with a clean base folder to verify that it's not what @@Langerd suggested, even though I'd expect an error message in the console if that was the case

 

Also check the file extension for typos - maybe you named your shader file .sahder or something like that, happened to me once and drove me nuts :D

Scerendo and Langerd like this
Link to comment

 

I increased the AO and saturation a tad.

 

At the moment I'm a bit stuck. My shaders are not working at all on the model, and I am not sure why. Also the lightsaber blade is missing in singleplayer.

 

There's no error message, in the console. 

 

The mesh itself is 5.9k triangles which is below that of Aayla and Quinlan, which I did not have any issues with - so I do not think its anything to do with the model's density.

 

For example a simple shader for the alpha that I have here:

 

 

models/players/st_poe/head_hair

{
    {
        map models/players/st_poe/head_hair
        alphaFunc GE192
        depthWrite
        rgbGen lightingDiffuse
    }
}

 
Does not even work. I've tried multiple different shaders and still nothing.
 
I'm using a 32bit .tga texture with an alpha. The alpha works fine in modview and other programs, so I'm not sure whats going on.
 
Anyone have any idea on what could be causing these issues?

 

Try deleting the shader from the pk3 and try again, if the issue goes away then it's a problem with that shader if not you can start narrowing it down.

 

Also for an alpha map shader this is the one I used for Kylo Ren and I didn't have any issues so maybe give it a go.

 

 

models/players/kylo_ren/extras

{
cull twosided
    {
        map models/players/kylo_ren/extras
        alphaFunc GE128
        rgbGen lightingDiffuse
    }
}
Scerendo likes this
Link to comment

The shaders not working on your model may have to do with the texture path written into the .glm itself. The game won't use shaders for models with " \ " in the texture path (within the .glm), so make sure you're using " / ".

 

Example:

 

models\players\sbd\body.tga --incorrect

 

models/players/sbd/body.tga --correct

 

Wow that was it. Didn't even notice that.

 

This is why I never will be a programmer!

 

Cheers pal, and thanks everyone for the suggestions.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...