Jump to content

CUSTOM SKEL NPC: AT-ST


Recommended Posts

NOTE: The JK2 AT-ST is different from the JKA AT-ST. In JK2, the "head" of the AT-ST can pivot independent of the legs on a specific bone. I can't remember the name of the bone, but it's apparently one which is near the waist of the player skeleton. I tried applying the ATST pivot code to the player and it sorta worked, there was just some minor animation issues.

Link to post

Holy Mother of God! That's awesome :OOOOO

Can we see screenshot how does it look like in game?

I could get a static version of the mesh ingame , but you'll have to wait for mini to see the actual animated model ingame

Link to post

NOTE: The JK2 AT-ST is different from the JKA AT-ST. In JK2, the "head" of the AT-ST can pivot independent of the legs on a specific bone. I can't remember the name of the bone, but it's apparently one which is near the waist of the player skeleton. I tried applying the ATST pivot code to the player and it sorta worked, there was just some minor animation issues.

 

@@eezstreet I didn't know this, thought they were the same. Are the skeletons different or is it just game code that is different because I built my skeleton identical to the base one from the source files but with my own shadow rig controlling it much like the _humanoid rig I released.

 

@@Grab, I have it at the point where it is ready to be animated, made a full rig (look a few pages back) so animations will be new so it's not even in game yet. I'm about to start animating it which is hard to say how long that will take since I'll probably post clips of it in Softimage for feedback on the animations snice the base ones weren't the best IMO.

DT85 likes this
Link to post

Anyone with both games installed wanna post ModView pics of both AT-ST's skeletons to check? My folder structure is already set up to let this version overwrite the base one so extracting them out would kinda bork what I've got going on.

 

I'm assuming this is what you mean.

 

JK2:

 

 

ta5Xvp.png

 

 

 

JKA:

 

 

QgXbXG.png

 

 

spacer.png

minilogoguy18 likes this
Link to post

shoutout to some people who might be able to help here : @@eezstreet @@Xycaleth @@DT85

 

Rend2 is giving me some funky results :

textures/models/atst/st_m
{
	q3map_nolightmap
    {
        map textures/models/atst/gray
        rgbGen vertexLit
    }
    {
	stage normalparallaxmap
        map  textures/models/atst/st_n
    }
    {
	stage specularMap
        map textures/models/atst/st_s
	specularReflectance 0.25
	gloss 0.1
    }
}

Ingame :

shot2014-08-08_04-40-18.jpg

 

 

This second shader , appears to work as it should ingame but sadly it looks like the model is allways lit from the same side , as If I baked a lightmap and put that on the model

textures/models/atst/st_c
{
	q3map_nolightmap
    {
	stage diffuseMap
        map textures/models/atst/gray
        blendFunc GL_ONE GL_ZERO
        rgbGen lightingDiffuse
    }
    {
	stage normalparallaxmap
        map  textures/models/atst/st_n
    }
    {
	stage specularMap
        map textures/models/atst/st_s
	specularReflectance 0.25
	gloss 0.1
    }
}

As you can see it's allways only the back side of the model that is lit , I tried r_forcesun 2 and it had absolutely no effect on the model

 

shot2014-08-08_04-37-33.jpg

 

 

EDIT : the lighting issue also appears with the vanilla renderer - no clue what's going wrong here

Link to post

For the diffuse stage, use lightingDiffuseEntity (in both shaders). And I can't remember off the top of my head if reflectance and gloss refer to the same thing. I think they do, so I would get rid of the reflectance lines.

Link to post

Try this:

models/players/<blah>/<blah>
{
    {
        map models/players/<blah>/<blah>.jpg
        rgbGen lightingdiffuseEntity
    }
    {
        stage normalmap
        map models/players/<blah>/<blah>.jpg
    }
    {
        stage specularmap
        map models/players/<blah>/<blah>.jpg
        specularReflectance 0.5
        specularExponent 16
    }
}

It's different for Ghoul2 models.

Link to post

@@DT85 @@Xycaleth Thanks but sadly the Lighting problems still persists :

-normal maps don't react to dynamic lightsources (could also just not have been implemented yet)

-the model is only lit from one side , it's probably some wierd exporter issue again though but I don't know what could cause something like this

 

Any ideas @@Psyk0Sith ?

Link to post

When normal maps display correctly in one package and are broken in another it's usually a shader issue or flipped channels. 3D studio max can't even display its own maps correctly because it has a "broken" or poorly written shader.

If you have an asset that displays correctly in JA, compare all the channels with your normal map and make sure they're matching the orientation (red and blue channels can also be inverted depending on bake settings). Also, JA's player models have a tendency to be lit from the back more than in the front, not sure why that is, but it could be a contributing factor. What happens if you rotate the AT-ST around before exporting? does the new back (the front) look correct? If so, then your normals are fine and the shader or the engine is breaking something.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...