Jump to content

JA: Enhanced Code Base


Recommended Posts

Hadn't checked my emails lately but got a fun one a few weeks back.

 

 

 

7oixFxC.png

 

 

Okay....Ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooof.

General Howard likes this
Link to comment

Really @@redsaurus, where's your defense speech?  :wallbash:  :starwars:  jk jk - nothing to respond there^^ Entitlement much?

 

Oh my, so much effort for such little message transported. I wonder how the author of above rant fares irl, especially when faced with anything rigorous with regards to autodidactic experience.

 

Btw... Idle animations fixed for me, regardless of cg_trueguns. That did not affect the issue prior. I think openjk introduced a few issues wrt to dismemberment that might have slipped in to JK:E not on your behalf. I will verify if my hunch stands the test.

 

So far thank you a lot for keeping up the updates!

 

BR

 

mjt

Link to comment
seta helpUsObi "1"

seta broadsword "1"

seta cg_g2Marks "1"

seta cg_g2MarksAllModels "1"

seta cg_saberEntMarks "1"

seta com_blood "1"

seta g_corpseRemovalTime "0"

seta g_dismemberProbabilities "0"

seta g_dismemberment "3"

seta g_saberDamageCapping "1"

seta g_saberLockRandomNess "1.5" (does this accept only integers or fall back to an integer?)

seta g_saberMoreRealistic "1"

seta g_saberRealisticContact "1"

 

I don't think any of those should be an issue.

General Howard and Smoo like this
Link to comment

If you would, please.. Yeah. I'm using the latest version of the mod's files (v1.06-alpha). Although, I have 2 GameData folders and JK:E is installed to the main JKA "GameData" folder (not the duplicate).

That shouldn't make any difference though, however. I've also rechecked my "jaenhanced" and "base" folders to make sure they're both "clean" of any other conflicting mods (which they are).

I also have "STAR WARS: Movie Duels" installed in the 2nd/duplicate GameData folder, but I can't see how that would interfere with JK:E's assets. I've also checked the vanilla game and oddly enough, the idle animations work as normal/intended. I hope this helps.. If you need any further info about the setup or files, let me know.

Thanks!

Link to comment

Backup your jaenhanced cfg, delete it and check if you have the same problems with default settings. If you do then there’s probably something wrong like an old dll lying around. If you don’t have a look which settings you’ve changed and let me know which is the one causing it.

Link to comment

Backup your jaenhanced cfg, delete it and check if you have the same problems with default settings. If you do then there’s probably something wrong like an old dll lying around. If you don’t have a look which settings you’ve changed and let me know which is the one causing it.

Alright, after following the tips, above.. I can confirm, that removing my "jaenhanced_sp.cfg" file from "C:\Users\XXXX\Documents\My Games\JAEnhanced\jaenhanced" did resolve the issue. I loaded the game/mod up, again (auto-creating a new "jaenhanced_sp.cfg" file) and idle animations are now working, again.

 

I'm gonna go through the settings, again and redo them as they were in my last .cfg file and check to see if the idle animations are still present. It may have been that the previous "jaenhanced_sp.cfg" file I was using, was incompatible with the newer version of the mod's assets, since I'd updated.. But don't quote me on that.

I'll test out the settings now and get back to you.

 

**Edit**

So, I've gone back to the settings and it seems to be (from what I can tell) something in the CONTROLS section, that may be bugging the idle animations out. I went in to the MOUSE/JOYSTICK section and switched the following options:

 

Smooth Mouse: Yes (was previously "no")

Enable Joystick: Yes (was previously "no")

 

Force Feedback: Yes (was previously "no")

 

Also, it may be worth noting that when the Force Feedback option is changed between Yes/No, there's a white message that comes up in the top left hand corner of the screen, that says: "unknown UI script UPDATE ff"

 

Before all this, I'd only gone in to the other controls area (not "OTHER") and made Force Power key bind changes. etc. and the animations were still working.

Anyway, I hope all this helps, in some way.

Link to comment

I think it could be from enabling the joystick. Is this using a controller? Does the same thing happen with the joystick stuff in base JA? What's your cl_run set to?

I have a controller plugged in, yeah. An XBOX One controller for Windows. Whether that's compatible with JKA or the game's code or not, I've no idea. Actually haven't gotten 'round to using it, yet. But switched the option on, in any case. And haven't played around with any joystick or controller settings. So, if it'd been turned on, it'll be set at the default settings for that option.

Link to comment
  • 2 weeks later...
  • 2 weeks later...
  • 5 months later...
  • 2 months later...
  • 1 month later...
  • 2 months later...

I'm having some issues. Initially, I downloaded the Moddb version and found this & overwrote the files but it resulted in a crash/pop up that said "couldn't initialize refresh" -- I figured out the culprit was the "rdsp-rendsaurus_x86" dll that was the culprit. Loaded it up and I can use the mouse to move the character around in the creation menu however whenever I attempt to select tint, it doesn't seem to work. Do I still need the other pk3s from the older version of the mod or no...?

EDIT: Whoops, yeah I need the other pk3s. All better.

Link to comment
  • 2 months later...
  • Circa changed the title to JA: Enhanced Code Base

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...