Jump to content

VM_create on game failed x_x (makermod compiled from source)

Recommended Posts

Sadly my hard drive got corrupted recently so all progress i made with improving Makermod was lost. i have re acquired MM source and opened the solution in Visual Studio 2013, and everything compiles like a charm, copied the dll files over to my makermod folder and start it up. so far, so good, however when i try opening a map, the game crashes telling me VM_create on game failed, which ive figure is an issue with the jampgamex86.dll. ive tried everything to my knowledge and really have no clue why it worked then and is rejecting it now. any ideas?








JAmp: v1.0.1.0 win-x86 Oct 24 2003
----- FS_Startup -----
Current search path:
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/makermod
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets3.pk3 (16 files)
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets2.pk3 (62 files)
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets1.pk3 (8320 files)
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets0.pk3 (15346 files)
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/base
23744 files in pk3 files
execing mpdefault.cfg
execing jampconfig.cfg
couldn't exec autoexec.cfg
...detecting CPU, found Intel Pentium IV
------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
...initializing QGL
...setting mode 6: 1024 768 W
...created window@3,0 (1030x797)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...57 PFDs found
...hardware acceleration found
...PIXELFORMAT 5 selected
...creating GL context: succeeded
...making context current: succeeded
Initializing OpenGL extensions
...GL_EXT_texture_compression_s3tc available
...no tc preference specified
.....using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_env_add
...GL_EXT_texture_filter_anisotropic available
...using GL_EXT_texture_filter_anisotropic
...Using GL_EXT_texture_edge_clamp
...using WGL_EXT_swap_control
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...GL_EXT_point_parameters not found
...GL_NV_register_combiners not found
...ignoring WGL_ARB_render_texture
GL_RENDERER: Intel® HD Graphics 4000
GL_VERSION: 4.0.0 - Build
GL_EXTENSIONS: GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_ARB_map_buffer_alignment GL_ARB_conservative_depth GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_SUN_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_ARB_texture_swizzle GL_EXT_texture_swizzle GL_ARB_texture_gather GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_ARB_transform_feedback2 GL_ARB_draw_indirect GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_ARB_texture_buffer_range GL_EXT_texture_snorm GL_ARB_blend_func_extended GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_geometry_shader4 GL_EXT_geometry_shader4 GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_base_instance GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_texture_multisample GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_ARB_tessellation_shader GL_ARB_vertex_array_object GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_texture_cube_map_array GL_EXT_gpu_shader4 GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_shader_subroutine GL_ARB_transform_feedback3 GL_ARB_get_program_binary GL_ARB_separate_shader_objects GL_ARB_shader_precision GL_ARB_vertex_attrib_64bit GL_ARB_viewport_array GL_ARB_transform_feedback_instanced GL_ARB_compressed_texture_pixel_storage GL_ARB_shader_atomic_counters GL_ARB_shading_language_packing GL_ARB_shading_language_420pack GL_ARB_texture_storage GL_EXT_texture_storage GL_ARB_multi_draw_indirect GL_ARB_program_interface_query GL_ARB_debug_output GL_KHR_debug GL_ARB_arrays_of_arrays GL_INTEL_map_texture GL_ARB_texture_compression_bptc GL_ARB_ES2_compatibility GL_ARB_robustness GL_EXT_texture_sRGB_decode 
PIXELFORMAT: color(32-bits) Z(24-bit) stencil(8-bits)
MODE: 6, 1024 x 768 windowed hz:60
GAMMA: hardware w/ 0 overbright bits
CPU: Intel Pentium IV @ 1796 MHz
rendering primitives: single glDrawElements
picmip: 0
texture bits: 32
lightmap texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
compressed textures: enabled
compressed lightmaps: disabled
texture compression method: GL_EXT_texture_compression_s3tc
anisotropic filtering: enabled  (16.000000 of 16.000000)
Dynamic Glow: disabled
------- sound initialization -------
----- Sound Info -----
sound system is muted
EAX 4.0 not supported
Eal file not loaded
s_EnvironmentID = 0
s_bInWater = false
No background file.
--- ambient sound initialization ---
Sound memory manager started
Loading dll file ui.
--- Common Initialization Complete ---
Winsock Initialized
Opening IP socket: localhost:29070
Hostname: Oliver-PC
]\map t2_trip
------ Server Initialization ------
Server: t2_trip
----- FS_Startup -----
Current search path:
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/makermod
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets3.pk3 (16 files)
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets2.pk3 (62 files)
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets1.pk3 (8320 files)
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\base\assets0.pk3 (15346 files)
C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData/base
47488 files in pk3 files
Loading dll file jampgame.
Failed to load dll, looking for qvm.
Loading vm file vm/jampgame.qvm.
Shutting down OpenGL subsystem
VM_Create on game failed


Link to comment

tried openjk with a default copy of makermod and didnt work..., has anyone else gotten it to run on it? and duuuh ive run as administrator, thats the first thing i tried lol

as for github, yeah i plan to start using that, dinnertime talked me into it xP

Smoo likes this
Link to comment
  • 1 month later...

Same issue here, compiling from source without any changes made. Tried both 2012 and 2015 compilers for all of Release, Final and Debug configuration. Had a friend of mine do the same with 2015 only, and his .dll yielded exactly the same result.


I'm guessing this isn't a problem with the source code itself, but what could it possibly be?

Link to comment

Have you tried it with jampded.exe instead of jamp.exe? I don't know if Makermod runs in jamp.exe by default because it has engine hooks built in that require the dedicated server exe instead (though I don't know if these are now automatically disabled when not running in the dedicated server).

Link to comment
  • 2 weeks later...

Any luck?

Hey, sorry was busy with uni stuff but I just compiled and it turns out there's errors in the botlib files, ill try fix em asap (oh wait isnt that just for cgame?) nvm still seems broken lol idk why. Also, noticed it compiles as JK2game.dll some reason, so i try rename it to jampgamex86.dll but still no good

Link to comment
  • 2 weeks later...
  • 2 weeks later...

Someone link me the source and I'll look at it later today for ya. Maybe if you're really lucky I'll create a CMake for it ;o


Edit: Is this failing for people who built it on their machine or is it failing for someone who's using a prebuilt version given out by someone other than the official makermod release?  If someone else, then most likely you need proper VS C runtime installed too.

Stoiss and Smoo like this
Link to comment

It built just fine here.  Failing during compile or failing with the error in the OT?


If the former try turn off building of botlib in all configurations as its unnecessary for mods always has been.


Problem with mm is that it has a bunch of patches built in which won't work unless you're using jampded and nothing else for engine.

Smoo likes this
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...