Jump to content

Alpha 2: Upcoming


Recommended Posts

The following is a short list of things which have been implemented in the next version:

  • TrueView (and TrueView 2.0)
  • SFX Sabers now look correct
  • Saber ignition flares now use the correct origin
  • Fixed an issue where loading from a savegame would give you incorrect battery charge and force power
  • Different saber ignition speed, depending on which stance you have equipped
  • nav delete now properly deselects the node you deleted
  • nav link can now accept two arguments, for selectionless node linking
  • nav delete now accepts an optional argument to delete a node without selecting it first
Maksman, hleV, Onysfx and 4 others like this
Link to comment

Probably a ways off, but it'd be great to have a Kyle customization menu using JA's species setup. I mean who wears the same clothes for days on end? I bet Kyle smells horrible.

Err...but how would you change clothes? Maybe an option in datapad?
Link to comment
Guest Redemption

Yeah, I was trying in vain to somehow implement some sort of costume change but I failed in the attempt :( It would add to immersion for an example, when you find the Shadow-trooper labs, you pick up a set; or it gets added to you're inventory and you could either select it via option menu or use it like when you activate a seeker drone. A lot of work maybe but, if there were anyone that can pull this of, it would be the people in this modding community.

Link to comment

I'm finding a bunch of weird glitches that I can't tell come from the build or a potential mod incompatibility. For example, Imperial Probe droids won't explode when "killed". They are still fully intact, but they won't try to attack me or move from one point to another. They can still animate and generate an electrical field when shot at. (Edit: Apparently, this was intentional? I have to say, I really don't understand this design choice. It's not like they're disabled and clumped on the floor. They're still floating and animated)

 

Loading screens show an image filled with bright static that really hurts my eyes after having to look at it for a while. I also can't load the Snowflake1 texture, meaning maps filled with snow, like the demo map, can't load. Doomgiver_shields also won't load music.

 

I hope none of these issues aren't just my mods making a mess.

Link to comment

Yeah, I was trying in vain to somehow implement some sort of costume change but I failed in the attempt :( It would add to immersion for an example, when you find the Shadow-trooper labs, you pick up a set; or it gets added to you're inventory and you could either select it via option menu or use it like when you activate a seeker drone. A lot of work maybe but, if there were anyone that can pull this of, it would be the people in this modding community.

Maybe the new costumes can be unlocked at certain points in the game. Like when completing certain objectives or something.

 

I'm finding a bunch of weird glitches that I can't tell come from the build or a potential mod incompatibility. For example, Imperial Probe droids won't explode when "killed". They are still fully intact, but they won't try to attack me or move from one point to another. They can still animate and generate an electrical field when shot at. (Edit: Apparently, this was intentional? I have to say, I really don't understand this design choice. It's not like they're disabled and clumped on the floor. They're still floating and animated)

 

Loading screens show an image filled with bright static that really hurts my eyes after having to look at it for a while. I also can't load the Snowflake1 texture, meaning maps filled with snow, like the demo map, can't load. Doomgiver_shields also won't load music.

 

I hope none of these issues aren't just my mods making a mess.

The floating droids not exploding is a deliberate design choice. They can still explode after death (either post mortem or while they are dying) from certain types of damage, like being hit with a rocket, sniper, or demp2. I might make this a toggleable feature. The probe droids don't have a "dead" animation yet though, so that is why they look weird atm. A compromise I am thinking of doing is just making their bounding box really tiny until animations are made, so they look like only the head is on the ground.

There is code for the head to actually come off like R5 units do, but that is a tale for another day.

 

Loading screen glitch is a known issue with the renderer, maybe @@ensiform knows how to fix it as he's dabbled with that code.

Snowflake shader is a new one, I can investigate that. I haven't actually tested this with the demo mission (shame on me!) but that's something to look at.

Doom_shields not loading music is an issue that @@mrwonko introduced to the game, you can blame him for it. :P I will look into fixing it though.

 

I can assure you that it's not your game though. Most of what you describe is stuff that I know about already and/or am in the process of fixing.

 

How does that make any sense?

Well, I received a request to make the lightsabers ignite faster ("like in the movies"). If you look at the anatomy of a lightsaber though, it's not a button that you push to turn on/off the lightsaber, it's actually a slider that you flip up/down (or a dial, in the case of Obi Wan Kenobi's lightsaber). I think the ability to turn on a lightsaber should be more analogue then and less digital. Of course that will impact gameplay negatively and make it clunky to turn on/off the lightsaber. One compromise is to make one style turn on the saber faster (blue), one to turn it on normally (yellow) and one to turn it on slower (red).

 

Keep in mind that this is an alpha mod, so it's very expected to find bugs at this stage. Keep letting me know about the ones you find!

Link to comment
Guest Redemption

Sometimes when I startup you're mod I get major stuttering and I have to exit, it says "WARNING: com_pushevent overflow" or something like that in the console :( It disables most of the rendering processes like r_ext_texture_env_add  and that. In my base I have an custom cfg file and I'm also using you're QEffectsPro.

 

 

helpusobi 1

seta ai_corpseCount 64

seta fx_flashRadius 4.0
seta fx_expensivePhysics 1

seta d_saberAlwaysBoxTrace 1

seta g_dismemberment 3
seta g_saberautoaim 1
seta g_saberautoblocking 1
seta g_saberBladeFaces 1
seta g_saberTraceSaberFirst 1
seta g_stepslidefix 1
seta g_synchsplitanims 1

seta r_ambientscale 0.01
seta r_cacheShaders 1
seta r_clampToEdge 1
seta r_colorMipLevels 0
seta r_depthbits 32
seta r_dlightBacks 1
seta r_ext_compiled_vertex_array 1
seta r_ext_compress_lightmaps 1
seta r_ext_gamma_control 1
seta r_ext_multitexture 1
seta r_ext_texture_env_add 1
seta r_finish 0
seta r_flares 1
seta r_ignoreGLErrors 1
seta r_intensity 1.2
seta r_lodcurveerror 250
seta r_lodscale 50
seta r_markcount 999999
seta r_modelpoolmegs 512
seta r_roundImagesDown 1
seta r_simplemipmaps 0
seta r_skinCache 1
seta r_subdivisions 4
seta r_surfacesprites 1
seta r_textureAnisotropy 16.0
seta r_texturebitslm 32
seta r_weatherscale 1

seta s_soundpoolmegs 32

seta ui_smallFont 0.1
seta ui_bigFont 0.1

seta cg_brasstime 999999
seta cg_fov 85
seta cg_gunX 0.75
seta cg_gunY 0.5
seta cg_gunZ 1.3
seta cg_marktime 999999
seta cg_speedtrail 0
seta cg_thirdPersonCameraDamp 0.25
seta cg_thirdPersonHorzOffset -0.25
seta cg_thirdPersonPitchOffset 2
seta cg_thirdPersonVertOffset 0
seta cg_thirdPersonTargetDamp 1

seta set sv_cheats 1

bind J ""
bind K ""
bind F4 "give all"
bind F5 "setforceall 1138"

 

 

Any ideas?

 

QEffectsPro also doesn't seem to work with the mod either :( Yeah sorry, I forgot that doesn't work with dynamicglow on :( Its a shame.

 

What is the cvar "sv_zombietime 2"? Is that the cvar that I can use to set the corpse removal time by any chance?

Edited by Redemption
Link to comment

Sometimes when I startup you're mod I get major stuttering and I have to exit, it says "WARNING: com_pushevent overflow" or something like that in the console :( It disables most of the rendering processes like r_ext_texture_env_add  and that. In my base I have an custom cfg file and I'm also using you're QEffectsPro.

 

 

helpusobi 1

 

seta ai_corpseCount 64

 

seta fx_flashRadius 4.0

seta fx_expensivePhysics 1

 

seta d_saberAlwaysBoxTrace 1

 

seta g_dismemberment 3

seta g_saberautoaim 1

seta g_saberautoblocking 1

seta g_saberBladeFaces 1

seta g_saberTraceSaberFirst 1

seta g_stepslidefix 1

seta g_synchsplitanims 1

 

seta r_ambientscale 0.01

seta r_cacheShaders 1

seta r_clampToEdge 1

seta r_colorMipLevels 0

seta r_depthbits 32

seta r_dlightBacks 1

seta r_ext_compiled_vertex_array 1

seta r_ext_compress_lightmaps 1

seta r_ext_gamma_control 1

seta r_ext_multitexture 1

seta r_ext_texture_env_add 1

seta r_finish 0

seta r_flares 1

seta r_ignoreGLErrors 1

seta r_intensity 1.2

seta r_lodcurveerror 250

seta r_lodscale 50

seta r_markcount 999999

seta r_modelpoolmegs 512

seta r_roundImagesDown 1

seta r_simplemipmaps 0

seta r_skinCache 1

seta r_subdivisions 4

seta r_surfacesprites 1

seta r_textureAnisotropy 16.0

seta r_texturebitslm 32

seta r_weatherscale 1

 

seta s_soundpoolmegs 32

 

seta ui_smallFont 0.1

seta ui_bigFont 0.1

 

seta cg_brasstime 999999

seta cg_fov 85

seta cg_gunX 0.75

seta cg_gunY 0.5

seta cg_gunZ 1.3

seta cg_marktime 999999

seta cg_speedtrail 0

seta cg_thirdPersonCameraDamp 0.25

seta cg_thirdPersonHorzOffset -0.25

seta cg_thirdPersonPitchOffset 2

seta cg_thirdPersonVertOffset 0

seta cg_thirdPersonTargetDamp 1

 

seta set sv_cheats 1

 

bind J ""

bind K ""

bind F4 "give all"

bind F5 "setforceall 1138"

 

 

Any ideas?

 

QEffectsPro also doesn't seem to work with the mod either :( Yeah sorry, I forgot that doesn't work with dynamicglow on :( Its a shame.

 

What is the cvar "sv_zombietime 2"? Is that the cvar that I can use to set the corpse removal time by any chance?

Corpse removal time is hardcoded in singleplayer and no cvar can change it. However, the corpse removal time was greatly increased in this mod.

 

sv_zombietime is not used in Singleplayer.

 

You can remove the following from your config because they aren't valid:

 

 

seta sv_cheats 1

seta ai_corpseCount 64

seta fx_flashRadius 4.0

seta ui_smallFont 0.1

seta ui_bigFont 0.1

 

 

 

Your game is getting spammed with some kind of keyboard/mouse/text event. This is why you're getting bad stuttering (console spam = bad performance) You could maybe try disabling QEffects but I seriously doubt that's interferring. Nothing in your config would be causing this kind of behavior that I see anyway. Does the problem persist when you sit still for a bit? Is there a joystick plugged into your machine?

Link to comment
Guest Redemption

Yeah, thank you for you're time eez, appreciate it. I have a Xbox 360 controller attached through xpadder pal. Love what you're doing; having a drink watching the footy, can't be of any more use at the moment

:-)

Link to comment

Yeah, thank you for you're time eez, appreciate it. I have a Xbox 360 controller attached through xpadder pal. Love what you're doing; having a drink watching the footy, can't be of any more use at the moment

:-)

This might be doing it? Maybe try disabling joystick input in the game? and trying with mouse and keyboard. I'm just throwing ideas out atm because I have no idea.

Link to comment
Guest Redemption

Well, sometimes it works with a little work around, I'm looking forwards to alpha 2, how are you faring with that?

Link to comment

Well, sometimes it works with a little work around, I'm looking forwards to alpha 2, how are you faring with that?

All listed things in the OP are things that I've done. I have been playing lots of the new Doom since then and haven't progressed much. On the plus side though, I've been a bit inspired by the Snapmap feature and might poke around with implementing an ingame kismet-ish scripting system for people to create scenarios with.

 

In terms of content, there's no good Scouttrooper models for JK2/JKA so I haven't included that yet. I might code the Stouker Concussion Rifle in soon. Still no mapper found for the lost mission.

Link to comment

I would keep saber ignition speed based on how fast a typical swing would go off, so by the time that a red swing is going to be in the optimal part of the swing (to the side or above directly in front of you, depending on the type of swing). Only thing is that the blue stance might be near instantaneous if scaled to this.

Link to comment
Guest Redemption

This might be doing it? Maybe try disabling joystick input in the game? and trying with mouse and keyboard. I'm just throwing ideas out atm because I have no idea.

It's looking more like that it is my xbox 360 controller; using xpadder, thats causing the stuttering :( How come it works fine in the base game but not this?

 

Maybe not, I think its in my mod cfg or something because the controller works fine with you're mod after removing my modded pk3 :(

 

Hello, 3rd edit so sorry, I got it all working, had to trim my cfg file and now JK2 Enhanced is going to be my foundation to build from :D

Edited by Redemption
Link to comment
  • 1 year later...
×
×
  • Create New...