Jump to content

mod overriding not working?


Recommended Posts

hey all,


i tried the newest OpenJK build for windows, and I have several .paks in my base folder that alphabetically override parts of other .paks (e.g. zzzz_redbowcaster overriding the bowcaster's green shots in zzz_customeffects), however they don't seem to override in OpenJK. So for the previous example, instead of getting red bowcaster shots I get green one's instead, while the rest of the effects are still the same from zzz_customeffects. why is this happening? i thought maybe the load order in OpenJK was reversed, but renaming the .pak files doesn't do anything. Neither does moving the .paks to the Documents base folder that OpenJK creates.

Link to comment

I have noticed a similar issue in JKG since we updated the codebase a while ago to more recent OpenJK. It will load assets0-assets5 and also JKG_ASSETS0-JKG_ASSETS5 but it won't let me overwrite anything from JKG_Assets, without me replacing the files in those PK3s.

Link to comment

well i guess i can provide the files i gave as an example ...





it's a crappy mashup of plagarized stuff, but i'm not publishing it anyway.

i was screwing around in SP btw, not sure how MP is. i thought i'd also try a couple older versions from 2015 and 2014, and they still have the same problem.

Link to comment

@@anxietymuppet can you try an older build to see if it works, or to find when it started breaking?


hi @@Xycaleth, i mentioned above that i tried 2 builds from 2015 and 2014 (around Dec.), and they still had the same issue.


however, here's where it gets interesting; so i thought before replying to your post i'd quickly try renaming my .pk3s again to load in reverse order in the 2014 build, but this time it worked. huh. so i reinstalled the latest OpenJK from 2016 and tried it again and it still worked. apparently if i rename a .pk3 that overwrites files with any letter not starting with z, the game won't allow it to overwrite files?


so for example, i previously renamed zzzz_red_bowcaster to b_red_bowcaster in order to override zzz_customeffects, which didn't work. this time i renamed it to z_red_bowcaster, which did work. i know the game is still loading .pk3s not starting with z, because i recently downloaded CamSP.pk3 and tried it in OpenJK, and it loaded fine. so um, problem solved? lol

Link to comment
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...