Jump to content

Blender Import/Export of .glm is giving inconsistent results (Saber held backwards when model is used)

Go to solution Solved by Droidy365,

Recommended Posts

A few weeks back I made a frankenstein model that has been working perfectly. This week I wanted to add some more to it so I added a couple other things. However when I exported this .glm it was broken. No error, the model looked perfect, the issue was that when you drew your saber it was messed up and held wrong. 

I tried to trace back what was wrong with it, and couldn't figure it out. So eventually I took the original model and imported the .glm into blender. Without making any changes i then exported the glm back and replaced it in the pk3 of the original (unedited) model. Despite that model working perfectly before, the same saber backwards issue occurred. So it seems like the issue is as simple as importing a working .glm and exporting it again will break it. I'm not sure if there's a setting I've got wrong in blender or if there's something else. Has anyone seen this before?

Link to comment

Hiya Pariah72.

One possibility is that your "l_hand" & "r_hand" triangles may be misplaced. If I remember correctly, where those triangles are, is where the lightsaber will be positioned (Not sure about the rotation of lightsaber though, but maybe that affects it too). So check that out and let us know how that goes!

Good luck!

Link to comment

I checked it in comparison to a different model and it's placed correctly. 

And even then, since I'm only importing a working .glm and exporting it back, no changes would have been to it after it was a working model.

Thank you for the suggestion, I was hopeful that was it.

Link to comment
  • 3 months later...

Hi, I'm having the same issue, I never changed the bones and all of a sudden the right hand holds the lightsaber backwards. The hand bone is the same to any non modded model. I tried flipping the right to match left and it still held it the same way. The only real change was adding a new object in the hirearchy, could that somehow break the bones? very weird bug. I'm using blender btw. It's the first time this happens.

Link to comment
  • 3 months later...

Did you find a solution to this? I'm getting the same problem. The model was working perfectly fine before, I haven't made any changes except for moving it to a different folder and back to Base. Exporting it from Blender is very inconsistent, sometimes both sabers are held backwards and other times only one of them is backward. Flipping them doesn't seem to fix it either.

Link to comment
  • Solution

They are tags, not bones. Two little triangles on the hands. It's a possibility that it may have been flipped around somehow. In blender, select the triangle on the right hand. Go into Edit mode, Press R to open up the Rotate menu. Then press either X, Y or Z to rotate along the appropriate axis. After that, type 180 (you don't need to click anywhere) and hit enter.

Link to comment
  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...