Jump to content
Sign in to follow this  
ShadowMarth

Animations set to one specific model [HELP]

Recommended Posts

Well, Im sure this has come up several times, and I've done my research as well as troubleshooted the hell out of this but I simply can't find the answer.

I followed both this guide:

http://jkhub.org/tutorials/article/105-creating-an-original-humanoid-file-unique-to-one-or-more-characters/

And the one katanamaru posted on post 8.

I think i went through both processes like 7 times each as well as did my own logical troubleshooting but It simply doesn't want to work.

 

I followed step by step to the "T" so that shouldn't need to be reiterated.

This is the error I am getting though:

"models/players/_humanoid_tiala/_humanoid_tiala.gla has no frames"

Then right after that it states "Animation file not found" For the model. And then forces the stormtrooper model to show rather than what its supposed to.

Both events file and animation.cfg are in the folder with the GLA.

As stated above my model name is "Tiala"

The model file and GLA file have both been CORRECTLY(According to the guides) edited with a HEX editor(tried both notepad ++ and HxD editors..no luck)

Am I missing something?

Share this post


Link to post

Does it work in modview?

I Get the MAX_QPATH error when I try to.

The default humanoid is in the right place in the players folder as well as the Custom GLA, named and placed appropriately

Share this post


Link to post

Hey there. 

If you followed it correctly like you said you did then it should have worked. Though I couldn't get it to work for one of the Starkiller models before. 

Try doing it with another model, and if it doesn't work still then try doing it with different animations. 

If the process is correct then it will work. If not then it is likely the steps.

 

Try undoing my backhand animations and then redoing it. Or changing that model to your animations.

 

Could you link to my original post too please? I can't seem to find it anymore.

Share this post


Link to post

Hmm maybe the name of the folder should be _humanoid_tiala but the gla file should be just _humanoid. Maybe try this too. Sometimes names of files reacts on the models... but this shouldnt work like that because path is IN the model.

Share this post


Link to post

Have you double-checked all of your paths to make sure that the file actually exists? Where is your GLA located?

 

^ also no, the path listed in that error is what the file needs to be called.

Share this post


Link to post

Hey there. 

If you followed it correctly like you said you did then it should have worked. Though I couldn't get it to work for one of the Starkiller models before. 

Try doing it with another model, and if it doesn't work still then try doing it with different animations. 

If the process is correct then it will work. If not then it is likely the steps.

 

Try undoing my backhand animations and then redoing it. Or changing that model to your animations.

 

Could you link to my original post too please? I can't seem to find it anymore.

http://forums.filefront.com/sw-jk3-modding-mapping-editing/432075-animating-dragon.html

It was on this forum. I will thoroughly run through the steps again today and try the differences mentioned. If it still doesn't work, I will then post step  by step what I did to help clarify.

katanamaru likes this

Share this post


Link to post

Found the answer lol I trouble shot using modview first. What I did was, in animation.cfg there was a line that was bad. I figured that out by setting it to the default humanoid.gla modview needs to open models and it gave me an error regaurding the BOTH_A3_SPECIAL animation. I didnt need that animation edited so I went to a fresh .cfg file and replaced the messed up animation name with the old default animation data. That allowed me to open it in modview. Once I had that done, using the HxD hex editor, I went to the file location line, and did this

 

models/players/_humanoid[Edit ->Insert bytes("_Tiala" is six characters long, so I added 6 bytes here)]/_humanoid[Edit ->Insert bytes("_Tiala" is six characters long, so I added 6 bytes here)]

Replaced the added bytes with "_Tiala"

After that i did this: models/players/_humanoid_tiala/_humanoid_Tiala(Right at the end here I removed 12 dots to realign the data to where it was before my edits)

Langerd and katanamaru like this

Share this post


Link to post

Found the answer lol I trouble shot using modview first. What I did was, in animation.cfg there was a line that was bad. I figured that out by setting it to the default humanoid.gla modview needs to open models and it gave me an error regaurding the BOTH_A3_SPECIAL animation. I didnt need that animation edited so I went to a fresh .cfg file and replaced the messed up animation name with the old default animation data. That allowed me to open it in modview. Once I had that done, using the HxD hex editor, I went to the file location line, and did this

 

models/players/_humanoid[Edit ->Insert bytes("_Tiala" is six characters long, so I added 6 bytes here)]/_humanoid[Edit ->Insert bytes("_Tiala" is six characters long, so I added 6 bytes here)]

Replaced the added bytes with "_Tiala"

After that i did this: models/players/_humanoid_tiala/_humanoid_Tiala(Right at the end here I removed 12 dots to realign the data to where it was before my edits)

I love when one stupid line ruins everything XD specially i love that in shaders - when i by mistake put a dot in one line in my shader the game didint load any shader in the game. Everything was bugged.

Share this post


Link to post

Heh yeah its incredibly bothersome. Im just happy I got it working.

Next i have to figure out this, what feels like impossible, Visual studio Openjk compiling.

Nothing I try works

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...