Jump to content

NPC Won't Spawn


Go to solution Solved by Circa,

Recommended Posts

So I just created an NPC for a custom model, courtesy of @@Asgarath83.

It spawned just fine for awhile, but suddenly it stopped.

I don't know how to fix it, help please?

 

Ahsokatano2
{
    playerModel        Ahsoka1
    weapon            WP_SABER
    saber            AhsokaADX
    FP_LEVITATION        1
    FP_PUSH            2
    FP_SEE            2
    FP_SPEED        3
    FP_ABSORB        1
    FP_HEAL            2
    FP_PROTECT        1
    FP_TELEPATHY        2
    FP_SABER_DEFENSE    3
    FP_SABER_OFFENSE    3
    FP_SABERTHROW        2
    forceRegenRate        75
    rank            ltcomm
    aggression        2
    aim            4
    evasion            4
    intelligence        4
    move            4
    reactions        4
    playerTeam        TEAM_PLAYER
    enemyTeam        TEAM_ENEMY
    class            CLASS_JEDI
    health            250
    visrange        2048
    hfov            160
    vfov            90
    vigilance        0.4
    yawSpeed        120
    walkSpeed        120
    acceleration        20
    snd            Ahsoka
    sndcombat        Ahsoka
    sndextra        Ahsoka
    sndjedi            Ahsoka
    dismemberProbArms    90
    dismemberProbHands    90
    dismemberProbHead    90
    dismemberProbLegs    90
    dismemberProbWaist    90
}

Ahsokatano3
{
    playerModel        Ahsoka1
    weapon            WP_SABER
    saber            Ashoka_bh
    saberColor        green
    saber2            Ashoka_bh
    saber2Color        yellow
    saberStyle        6
    FP_LEVITATION        1
    FP_PULL            1
    FP_PUSH            2
    FP_SEE            2
    FP_SPEED        3
    FP_ABSORB        1
    FP_HEAL            3
    FP_PROTECT        1
    FP_TELEPATHY        2
    FP_SABER_DEFENSE    3
    FP_SABER_OFFENSE    3
    FP_SABERTHROW        2
    forceRegenRate        75
    rank            ltcomm
    aggression        5
    aim            4
    evasion            4
    intelligence        5
    move            5
    reactions        5
    playerTeam        TEAM_PLAYER
    enemyTeam        TEAM_ENEMY
    class            CLASS_JEDI
    health            250
    visrange        2048
    hfov            160
    vfov            90
    vigilance        0.4
    yawSpeed        120
    walkSpeed        120
    acceleration        20
    snd            Ahsoka
    sndcombat        Ahsoka
    sndextra        Ahsoka
    sndjedi            Ahsoka
    dismemberProbArms    90
    dismemberProbHands    90
    dismemberProbHead    90
    dismemberProbLegs    90
    dismemberProbWaist    90
}
 

 

Link to comment

The npc file is Okay. The jedi class AI about enemy chasing is littel weird... can you explain what you mean exactly with "stop"?

the npc is freeze out? or they simply point at enemy distance but they not chase and engage the enemy? if you got this issue, put the aggression and move value to 5, also rank can affect the NPC behavour against enemies. more is the rank, more aggressive they are.

also, can be a map problems. if there is not a good waypoint connected net to guide the NPC into they runs and battle, they can stops without many sense... :|

Link to comment

Just type that in the console, it's a console command: cl_noprint 0. Though if you read anything in the console and it writes down a list of the previous commands, you should assume it's already set to 0. In that case, all I can think of is to check out the model path.

 

Also, did you change anything before the NPCs stopped spawning?

Link to comment

Don't know, but I've removed a lot over the past few days. 

When I open up the file in NPCTool, it'll give the name of the NPC, and when I go to the appearance tab, the field where you select the skin (red, blue, default)- the field is always blank. I fill in the field with default and save it, but still nothing.

EDIT: I even remade the folder paths in the PK3. Models/players/Ahsoka_Tano. I checked all the .SKIN files. I just don't know what to think.

Link to comment

Oh my goodness,  that's funny. Thanks alot Circa!

How's Tatooine btw?

Also, you think it'd be okay to use this port in our little project when we get to CWA or should we just stick to Hirman/Offspring's model?

Not sure. That'll be far down the road though. :P

spacer.png

Link to comment

Very very, lol. We'll get there tho. Been working on a NOVA trooper, thought it'd be a fun one to parouse your beautiful Tatooine creation with for that one SP mission. I was thinking it could be a squadron of Sandtroopers and NOVAtroopers searching for the droids.

Any ideas to make the black textures shiny instead of dull and matted? Isn't that a shader job?

Link to comment

Very very, lol. We'll get there tho. Been working on a NOVA trooper, thought it'd be a fun one to parouse your beautiful Tatooine creation with for that one SP mission. I was thinking it could be a squadron of Sandtroopers and NOVAtroopers searching for the droids.

Any ideas to make the black textures shiny instead of dull and matted? Isn't that a shader job?

Yep, you'll need a shader.

 

And yeah, haven't even started the map yet. Haven't touched my other map in a couple weeks. Been busy with classes and such.

spacer.png

Link to comment

Yep, you'll need a shader.

 

And yeah, haven't even started the map yet. Haven't touched my other map in a couple weeks. Been busy with classes and such.

Man who cares? We got all the time in the world. Life is super busy at this time because the ending of trimesters-so on and so forth. I feel you lol I've been working hard for two weeks and I'm still bombing a class.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...