Jump to content

Map Failing to Load

Go to solution Solved by MagSul,

Recommended Posts

^ Basically, I've been compiling a level and running around without an issue. However, if I /devmap to restart the same level while I'm in it, the level doesn't load. More worryingly, if I load this level from a target_level_change in a previous level, I also get this error, as demonstrated in the video.

I'd just like to know what directly causes this and what I can do to ensure it doesn't happen. If anyone's able to steer me in the right direction, it'd be appreciated. 🙂

Link to comment

Very strange. I've only seen this type of behavior in MP, when trying to load a map after connecting to it and somehow disconnecting from the server. I can only think it could be related to entities, so my suggestion is to try that way, start removing and see if this fixes it.

MagSul likes this
Link to comment
  • Solution

I seem to have fixed it! My info_player_start is targeting a target_scriptrunner that does the opening cutscene etc. The same script also fires another target_scriptrunner that spawns a load of NPCs. All I did was add a 1 second wait time to the NPCs spawning in and magically it's happy to work. 😊

Kessno likes this
Link to comment
On 11/25/2022 at 8:05 AM, mrwonko said:

Can you share the broken version of the map? This looks like a bug in the code that should be fixed, but we'll need a way to reproduce it first.

Sorry, I was away for the weekend! I didn't keep a copy of the map in that state, I'm afraid. Once I swatted the bug, I just ploughed on through. Just very eager to get to my next update! 😁
I'll keep this in mind if I run into similar problems with the next level. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...