Jump to content

Crash upon trying to load into a server


Recommended Posts

Hi guys,


I kinda failed using the wrong system to report a question rather than a bug, and I apologise for wasting time/resources because of this. So maybe I will post this here, in-case it is not a bug again and its a user error on my part (most likely).

Ironic thing is I can figure out errors on the server side of this mod and I get stumped on the user side, something wrong with me? who knows!


I have fresh install of JKA (From CDs) - Openjk on and I am running the openjkx86 shortcut


When I try to go into server, it crashes on me and throws me into desktop


Event viewer shows me this:


Faulting application name: openjk.x86.exe, version:, time stamp: 0x527baa9b
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00439470
Faulting process ID: 0x91c
Faulting application start time: 0x01cee1cbaed4894c
Faulting application path: C:\Program Files (x86)\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\openjk.x86.exe
Faulting module path: unknown
Report ID: f53e8bb0-4dbe-11e3-bee3-ce8599e1bb9d
Faulting package full name: 
Faulting package-relative application ID: 



System: Win 8.1 Pro (all updates done as of post date), ATi 7970 3GB (Latest Drivers, 13.9)


Any help is appreciated, thanking in advance for your time

Link to comment

Yes I did this, and confirmed it as working!


But when launching Openjk as opposed to jamp, nope!


devmap no work either!


when I launch jamp.exe and load as a mod openjk, it works


wheni launch openjkx86.exe and try to join any server, it doesnt work!!!


now i am confused as hell!!!

Link to comment

Out of curiosity, did you compile openJK yourself or are you using one of the prebuilt ones from buildbot?


I've been able to connect to JA+ servers fine.  Has anyone else been able to reproduce this?




For those questioning version info above, I'm pretty sure the embeded versioninfo for the executable is just so its not that he's not using

Link to comment

eezstreet - yes but i think i have solved this issue of mine


enisform - i donwloaded 7th Nov from buildbot builds


Guys I cracked it


turns out JA+ and JA++ do work as intended


in this directory!!!!! --> C:\Users\<<user>>\Documents\My Games : This openjk folder was the cause, files in here looked fine, but this directory I think was somehow not right, so I let it make a blank new one.


I reinstalled game, and renamed this folder to old. each time I used openjk and launched the server that would make me crash.

Installed patch, then OpenJK - worked

Installed custom pk3s and cfgs etc - Worked

installed JA+ (defualt cfg) - Worked

Installed JA+(my own cfgs) - Worked

Installed JA++ (Defualt cfg) - Worked


I am now constantly using the exe of OpenJK and it works multiple times.

I think this issue is cracked, and I think I shoulda checked this sooner, maybe me moving from Steam version to normal disk based did this, Im not sure!!


Something to note down Dev's, when a Switch happens from Steam to Diskabsed or vice versa, that openjk needs ot be replaced (ofc you knew this, but if I say it it doesnt make me sound so dumb :P)


Thanks to anyone who gave their time in helping/answering!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...