Jump to content

Cannot Save Created Levels


Recommended Posts

I am having a real problem with “GtkRadiant-1.4”, I cannot save any levels because when I do I get this error

 

 

ERROR: couldn't open D:/Program Files (x86)/GOG Galaxy/Games/Star Wars Jedi Knight - Jedi Academy/GameData/base/maps/TestmapNo brushes selected.
 for write

 

 

I have tried starting the program in administrator mode but that does nothing. Does anyone know any way to fix this?

Link to comment

A few things I would try.

First, make sure you are not using "Save Selected".

If that fails, create an empty text file in your base/maps folder, rename it to <yourMapName>.map, and try to save over it in radiant.

If all else fails, go into Radiant's preferences, find and toggle the "Use Win32 dialog box" setting, then try saving again to see if that works.

Link to comment
12 minutes ago, NAB622 said:

A few things I would try.

First, make sure you are not using "Save Selected".

If that fails, create an empty text file in your base/maps folder, rename it to <yourMapName>.map, and try to save over it in radiant.

If all else fails, go into Radiant's preferences, find and toggle the "Use Win32 dialog box" setting, then try saving again to see if that works.

I was using “save as” and “Save”, I had never touched “Save Selected”.

 

I have the same error when I tried to save over the file and I found that “Use Win32 dialog” was already activated.

Link to comment

Try disabling the win32 dialog, too. If that doesn't work, I'm out of ideas.

You might be able to copy and paste your work into a different version of Radiant and save from there, but that's a long shot.

NumberWan likes this
Link to comment
23 minutes ago, NAB622 said:

Try disabling the win32 dialog, too. If that doesn't work, I'm out of ideas.

You might be able to copy and paste your work into a different version of Radiant and save from there, but that's a long shot.

OK, that solved it. Thank you, I was beginning to think that I would never get this program working properly.

Link to comment

If I remember correctly the saving is broken in 1.4 from Windows 7 onwards (possibly Vista, too). The code was just plain wrong and only worked by accident in earlier Windows versions.

I think there were two workarounds (besides updating to a newer version): either you can manually add the ".map" when saving the file, or you can go to the preferences and switch to an alternate version of the load/save dialog, I don't remember what exactly the option is called.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...