Jump to content

GTKRadiant Warning and in-game problem.

Recommended Posts

Hello everyone!


I have been working on a map lately and I attempted to add switchable lights via a trigger_multiple. When I do so, though, I receive spam warning while compiling.


"WARNING: Hit per-surface style limit (4)"


Whenever I compile without the trigger, it is done normally and there are no issues. Whenever I test the map in-game with the Warning, the room that the light is located have other surfaces receive lighting as normal and others appear totally black, like there's no lightsource at all.


I have to note that while the map has several rooms, this is tested in one room with a single light entity. Also, that light entity has no additional styles, but the targetname.


I have tried:

- With and without start_off.

- Adding an extra always active light entity with low light.

- Tried with stronger light.

- Tried different textures on the surfaces that are "black"

- Tried on other rooms, same issue.



Note: The weird thing is, that I have added first in another room, two small spotlights with trigger on their own that work just fine. Beyond that point, any other light gives me the error.


I would appreciate if anyone has any idea ?

Link to comment

Any time you have switchable or styled lights, there is a limit of 4 styles on every surface. The only way to exceed that limit is to change the source code and recompile.

There are a few things you might be able to do to reduce the number of styles you are using, but I have to ask; are you trying to make rooms with a single switched light per room, like sithcouncilv2, or something more elaborate? There might be some other things going on as well.

Link to comment

I checked sithcouncilv2 for the reference. I am actually -aiming- for something more detailed, but I started simple to get an idea of how it looks and I got the error. So what I am trying right now is pretty much like the bedrooms in the sithcouncil, but no colored lights or anything.


The room right now that the error occurs have only a single light. To be more precise:




(It is not connected with the trigger in this image. Also top view)

Link to comment

Yeah, there's no reason that should be giving you the error.....Do you mind if I were to take a look at the map file? I might be able to help.

From what I'm seeing right now, though, it looks like it just might be light leaking between the rooms somehow.

MagSul likes this
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...