Jump to content

Low FPS problems


Recommended Posts

Thanks! So does this only occur on multiplayer servers that run modded?

 

Have you compared running with r_fullscreen 1?

 

seta cg_renderToTextureFX "1" also works fine? I mean I really can't find anything in the config that should cause FPS drops or any other form of trouble.

 

Can you point me to the servers? Where do I find them?

 

I'm willing to start with a fresh GOG JKA installation and let the servers download stuff and see if I come out with the same issue...

Link to comment

It really does seem to be that there's a decrease in natural performance when switching over to a JA+ server, yeah. I'm going to try your suggestions and add them to the config and do a retest for you. Just keep in mind that going from OpenJK to normal JKA didn't really make a difference so, we already tried that. Let me try to write out each IP address for you.

 

Auora's Base server:

/connect 188.68.55.162:29070

JP Community Server:

/connect 63.251.20.144:29070

KR Clan Server:

/connect 192.223.29.244:29070
Smoo likes this
Link to comment

So I did some research and I found out that my motherboard has an actual physical switch for what they called "Core Unlocker." Here's the web page for my motherboard.

 

https://www.asus.com/Motherboards/M4N98TD_EVO/

 

If you scroll down, one of the features is "Core Unlocker" and it shows that when it's the LED is turned on with a red color. I checked through my clear plastic side panel and saw that the only red light I saw was coming from my fancy graphics card. So, I turned it off and took a good look where the switch was and flipped it on. The red light came on when the power came on and after I turned it on the BIOS showed a picture of a processor with an arrow sweeping upward.

 

The thing is though, I'm not sure how much it helped... I was starting up JKA and changing the priority. I tried setting it to real time and then to high. It didn't seem to help performance any with FPS dipping up and down so much. It wouldn't be so bad if it didn't dip down below 30 FPS because, then the game gets really choppy. Anyways, I thought maybe I just didn't have a good enough processor. I looked online and found the best one my motherboard supports.

 

https://www.amazon.com/AMD-Phenom-1090T-Processor-HDT90ZFBGRBOX/dp/B003FVI2KQ/ref=sr_1_1?ie=UTF8&qid=1495303609&sr=8-1&keywords=phenom+ii+x6

 

It's not a bad price for something like that and I wouldn't mind upgrading again. However, a fast memory upgrade will cost me $220 for two orders of 8 gigs of those things. That's a bit pricey but, I really want this game to work. Maybe it is a driver issue but, all the updates I ever get are Game Ready updates for new game optimizations. I could try just cutting out Geforce Experience but, I know if that will work either.

 

The more I've thought about it, the more I'm starting to think it's one of my memory sticks going bad. I remembered that when I upgraded my memory, my computer was running a lot worse than before. So I might have to dish out some cash to get a better brand or something. This next link is what I'm thinking about getting. Would two orders of these work?

 

https://www.newegg.com/Product/Product.aspx?Item=9SIA4YU2HT6594

Smoo likes this
Link to comment
  • 3 months later...

That doesn't really make any sense because neither the original game nor OpenJK were ever compiled against Visual C++ 2005. The former for obvious reasons, and the latter because we had a minimum of 2010 as oldest originally.

 

Coincidence perhaps?

I'd like to think that it was just a coincidence but as I've just stated earlier, it was actually a couple older games that did have some form of slow down issues (I just didn't realize there might have been a connection). I recently read on gog's website that GoG Galaxy will introduce cloud saves and I was excited for that. While downloading my titles with this program, it had also installed that one version of Visual C++. However, I hadn't played anything until the next day. I popped on Steam and played Age of Empires 2. When I started up a game, it was smooth as it should've been. Character movement was smooth and scrolling around the map didn't lag so hard like it had been doing.  I was shocked by all this and tried JKA ... same thing. It's like the problem just disappeared and seeing the date that it had installed the program makes me think that's what did it.

 

I know Steam also tries to install versions of Visual C++ and that's where my copy of JKA and Age of Empires 2 HD comes from. Only Geneforge is a GoG game and that's a copy I got online from someone else.I hadn't changed anything hardware wise since upgrading to 16 gigs of DDR3 ram and software wise was just a bunch of old games from GoG, their Galaxy program, and that new version of Visual C++.

 

The only other thing could be that Windows Update had reset a bunch of settings, things like firewall exceptions and preferences that were defaulted. Could it be something like that? I also had resurrected my Windows 10 from a massive msconfig screw up before that. Had to command line boot mode back into legacy using a recovery disk. Everything came back fine but, I hadn't seen improvement shortly after that either. Any other ideas or maybe someone else might have an idea why a certain version of Visual C++ 2005 would make a difference?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...