Jump to content

Game crash and dismemberment not working

MoJo JoJo

Recommended Posts

I'm not sure if I'm posting this in the right place or not, but I have two big problems, or at least one of them is big. The big problem is that when I'm fighting jedi/reborn, or if there is other jedi and reborn fighting, the game will just out of nowhere randomly crash.

The second problem is that when I have g_sabermorerealistic on, bodies don't dismember. Every once in a great while when I'm playing a campaign mission an NPC or two will dismember. Very annoying. Is there anyway I can at least fix the dismemberment?... I know a lot have people have come here and reported the game crashing problem, but anyway a solution to the problems would be appreciated.

Link to comment

I do have g_dismemberment set to 3. I could have either debug_subdivision on, or g_sabermorerealistic with g_dismemberment on 3, but it still doesn't work.

Idle saber damage DOES work, it's only the model dismemberment that's not working. I'm not sure why. The builds have that problem now.

Link to comment

It's set to 1. I looked in the code and say this: "0 = ignore probabilities, 1 = use probabilities". basically what that means, is if it's set to 0 then all limbs have a 100% chance being cut off, and that being only 1 limb. If set to 1, then probabilities is based on what is set in the NPC files.

I'm not sure. I could be the only one having this problem, but I don't have this problem at all in JK2, just JA.

Link to comment

I thought the g_dismemberprobabilities setting was percentage based in JKA... Try 99.




Also, make sure that you have no mods installed that change the default game's NPC stats, as these may change the dismemberment settings on these NPCs as well.

Link to comment

No mods. Tried every number from 1-100. I think this problem has something to with entites, because I've played around in duel maps from MP the more I spawn and kill, the less that are dismembered. It actually DOES work but VERY LITTLE. When I spawn a lot of stormtroopers or whatever it no longer works until it's all cleaned up.

I'm probably the only one having this problem, so if you've download one of the recent builds and have had no problems, then it's probably just me. I don't know why it would be though. The earlier builds didn't have that, however I have the code back at that time and had that problem, so I don't know.

Whoops typo. Meant to say that I have COMPILED the code back at that time and had the problem. I didn't know if you guys knew about this, I figured maybe you did.

I code some, but I am no genius at it by any means.

Link to comment

I can only tell you how it works for me:


Depending on the NPC's settings, dismemberment is more or less likely to happen based on the kind of NPC, but overall there's about a 30% chance on NPCs' bodies getting dismembered. I have g_sabermorerealistic on 2, g_dismemberment on 3, and g_dismemberprobabilities on 40. I'm running an April 2015 release of OpenJK.


The "the more NPCs the less dismemberment" implementation seems logical if we take game performance into consideration, so it's possible that that is a factor.

Link to comment

Yeah the same settings that you have set currently worked for me to on the older builds. For some reason now it doesn't work very well on the newer ones. I'm not sure what was done, but I am pretty sure it's got something to do with how much entities there are. But yeah I could have the dismemberProbs all set to 100 in the NPC files and g_dismemberProbabilities set anywhere from 0-100 along with g_dismemberment on 3 and g_sabermorerealistic on 2 or 3 and it'll work until too many entities are already in-game.


Like for example I've been on the mp/duel1 map I could spawn like 7 stormtrooper or so in a line form... They would most likey all dismember, but I would spawn 7 or so more and suddenly won't dismember at all, not one limb comes off until it's all cleared out.

Link to comment

Yep, that sounds like a programmed cap on the model dismemberment, probably implemented as a safety (or performance improvement) feature.


Edit: This topic should probably go in the OpenJK forum, as it's an issue specific to the latest release(s) of OpenJK.

Link to comment

The original JASP had the problem but slightly. It had been corrected by OpenJK and suddenly now it no longer is and it's actually worse that it was in the baseJKA.

That sounds a bit strange. Are you sure it's not just the type of NPC or a chance factor?

Link to comment

If you download the latest build and then start it and then turn on g_sabermorerealistic along with all the other cvars you use to get it to work, chances are only a few will fall apart and the rest will not.

Yeah I know they haven't changed. I use them as they're supposed to be used.

Yeah sorry about all this. I thought maybe you knew about it, or knew a way to fix it, nothing big really. If you're not sure how to get around it it's fine.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...