Jump to content
Sign in to follow this  
afi

openJK not compiling correctly?

Recommended Posts

So I downloaded the latest version of openJK and tried to compile it (which is working) but ingame it's a bit weird. None of my code edits seem to be in the game except for the fact that it displays the name of my mod on the right side of the console. But gamename and gamedate is still "basejka" and "Nov 6 2003". Everything is compiled and in the right place...

 

 

Share this post


Link to post

I actually had this problem when I was trying to modify the source code. Where are you putting the code? If I remember correctly you have to put your code in the MP Client source folder, not MP Game library. Also, depending on what you are doing, you might not have registered what you did correctly. I remember to write a console command I had to write a function for it in addition to "registering" it as a variable somewhere.

 

I could be wrong though and there's people on here that know a ton more about this than me.

Share this post


Link to post

It could be any number of problems...

 

  1. It might be loading the DLLs from your My Games folder. This is the preferred location to put mods... 
  2. If you're making a new 'base', then make sure the DLL isn't being loaded from the assets PK3s. You can get around this by packing your DLLs in a PK3 and giving it a name that comes after 'assets' in the dictionary..
  3. You can also get around 2) by turning off sv_pure (I think?)

Share this post


Link to post

Thanks, it's actually working now. I'm not sure why though. I've deleted all dlls (even those in the pk3s and in the my games folder) but it still happened and after a couple hours I compiled everything once again and suddenly it was working.

Share this post


Link to post

May I ask what exactly you did? I'm having the same issue and i do have it in the OpenJK/base folder.

Also could it have anything to do with the file size? the default Openjk jagamex86.dll was 2.21MB and the one I'm trying to use is 4.81MB

I only edited 1 line. Which was including a header.

Share this post


Link to post

As I said before, I'm not sure what exactly fixed it But I deleted all .dlls in all folders and even opened the .pk3 files and deleted the .dll files in it. I also made a new command called "gametime" ( __TIME__ in the game xcvar_table) so I can be sure that my build is up to date.

Share this post


Link to post

Release gives me 4.79MB. and I tried removing the .dll files and no luck with the "Failed to load jagame libary" error.

I'll keep trying to trouble shoot. If there is anything else I can try please tell me.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...