Jump to content

Problems with swapping from single to dual sabers mid-game

Go to solution Solved by redsaurus,

Recommended Posts

I've been playing through Jedi Academy with JA Enhanced enabled, and it has been pretty fun. However, either in the Vjun level or the level before it (the prison break, cuz I fiddled with my player character at some point), I swapped from single saber to dual sabers, with my roleplaying headcanon saying that Jaden decided to grab a second saber while resting at the academy to see what it was like. However, it got rid of the Taka attacks (I love the long blurs they make) so I tried to switch back and even to saber staff, and these issues occurred:

  1. It wouldn't make the switch persistent, though it would let me switch to fast attack style (when I unlocked heavy, it wouldn't)
  2. If I did manage to get it switched, Jaden's animations were broken. They would go into the T-pose, unable to move (though I could still jump), and if there was some animation blends, they would freeze until they blended back into the T-pose.
  3. This also broke swinging animations, and made Jaden swing incredibly fast (seemed to be effective at cutting down enemies, interestingly enough, just couldn't actually move without jumping)
  4. If I switched to saber staff, the animations for walking would default to the dual sabers one but only on the first frame. I could move, but the model wouldn't animate. When I stood still, Jaden's arm holding the saber staff would flicker between two positions very rapidly.

I tried various was to fix it, including jumping between savegames (with limited success), but I found that if I enabled cheats, typed in

saber single_1

into the console, which would force switch to a single saber, and then redid my customization options, it fixed the issue. So there's a workaround, but this seems like a pretty infuriating glitch. Is this a known issue?


Link to comment
  • Lancelot changed the title to Problems with swapping from single to dual sabers mid-game

Some of this are known issues, though it is not unique to JAEnhanced, it is just more common because of the menu I built in to freely switch your sabers. However I've never noticed the t-pose issue or the fast swinging. I can try your various methods to see if it can all be reproduced.

Perhaps @redsaurus could find some solution in the code or menu to select the stances someone wants and fix the issue with going from staff to single. I believe changing those things in the menu are more limited with the existing code, causing some of these things.

Smoo likes this
Link to comment

It was dual sabers, not staff, sorry. But idk, maybe that breaks it too? I didn't try.

I think the problem might have been I changed it on Dosuun (I think that's the prison break one), where you didn't have a lightsaber until the very end, if at all, and that might have made things a bit screwy. I don't know for sure though. Though I'm not sure how that glitch would have persisted between levels if it reloads your loadout every time...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...