Jump to content

OpenJK with Jedi Outcast-Academy Mod


Recommended Posts


I've come to OpenJK rather late and as well as the normal JK gameplay, I use the following mod to play Jedi Outcast campaign with Jedi Academy core.


However since modifying the launch .bat to run off OpenJK-SP instead of jasp, I've run into a handful of issues.


A couple of them I have already fixed such as:

- shader problem that left all characters transparent and certain level scenery textures missing

- "couldn't load item for weapon_trip_mine" error message at the start of new game, which ended the current game

In both these cases I copied the JA versions of the shaders and the items.dat from the JA assets pk3 and added it into JO assets to fix the problem.


But one other problem that seems to be impossible to rectify is seeing "couldn't find weapon for weapon" error appearing at the start of most new levels, ending the current game.

I thought that this was due to the JO version of weapons.dat, but after copying it into the JO pk3 the same way as with items.dat above, it is making no difference.

If I want to get to the next level then I am having to use the "map" cheat code before the previous level's ended.


I have noticed, and this might be part of the issue, is that at least according to the command window OpenJK is searching through folders and loading pk3s in *reverse* alphabetical order.

Typically JA should be loading packages in normal alphabetical order, and if you have a relatively comprehensive mod then certain things need to be loaded in a specified alphabetical order.

It would result in problems to have it read in reverse.


Is the loading order "known about" in OpenJK and has it resulted in similar issues as above?

Anyone know what my unshakeable error could mean and where I should look for a fix?


Link to comment
3 hours ago, Circa said:

PK3 load order doesn’t change in OpenJK, it was always loaded in reverse order.

Are you sure these issues don’t appear when running with jasp.exe? Does OpenJK run fine without this mod installed?

If pk3s have been loaded in reverse order since the start, why do we bother adding Zzzz etc to the front of files we want to load last?


OpenJK runs fine with normal JA single-player and multiplayer.

And this mod runs fine with jasp.exe except for memory issues if certain mods are installed alongside.

Link to comment
2 hours ago, triplex said:

If pk3s have been loaded in reverse order since the start, why do we bother adding Zzzz etc to the front of files we want to load last?

That's because the game won't load resources it has already "seen". So things you consider to be "loaded last" are actually loaded first and everything with the same name will be ignored afterwards.

Link to comment

In other words, the load order doesn’t override the previously loaded items, they would just be skipped. A bit different than other games like Skyrim and KOTOR.


Only other thing I can think of causing issues is other pk3s in the OpenJK folder rather than the base folder. Either in Gamedata/Openjk or Documents/My Games/Openjk.

Link to comment

Ah okay.

In which case my first fixes make no sense as they shouldn't have worked. In reverse alphabetical order the JO assets pk3s should have been loaded last and anything duplicated from JA ignored.

I currently have no pk3s in OpenJK, just in base and JOA for this mod. I'll have a look through and think whether anything weapon-related might be causing a clash.

Link to comment

I think I've found the source of the issue but why it's happening with OpenJK and not jasp I have no idea.


There seems to be some conflict between the weapons selection of JO and JA, whereby playing the JO campaign seems to exclude the Concussion Rifle from the weapons selection, and so it trips up trying to load what is sees as non-existent weapon.

As I've said this wasn't an issue when running off jasp, seems to be new with OpenJK.



* I think it's now fixed *

I put copies of the JA weapons and items .dat files into Zzz_JOA_Base_Assets_v3 (1).pk3 so that they're read a little earlier in the chain and it seems to not be crashing with that error anymore.

Link to comment
  • 1 year later...

Same problem here,,,"couldn't find weapon for weapon" error in Jedi Academy using the ultimateweaponsjk2 mod.


The ultimate weapons pk3 was missing some items like wp_concussion, etc that WERE in the original game assets, possibly because it was made for Jedi Outcast? Dont know.

So....with 7zip open the original game assets1.pk3 file and copy weapons.dat file from the ext_data dir.

Then go into ultimateweaponsjk2.pk3 and paste it into the ext_data dir there. You will have to edit some- everything was identical except for some ammo values, so i changed them to the mod file values and voila, it works now.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...