Jump to content

Compiling error with entity modding

Recommended Posts

Hi everyone!

I've just got introduced to entity modding and I wanted to experiment with it but something always goes wrong.

So I've read these tutorials:


I think I've done everything as the tutorials say but I get the following error:
"Error opening C:/Program Files/GtkRadiant-1.4/filename.ent: No such file or directory"

The directory exists and there's no spelling mistake, I double checked it, and both the .bsp file and the .ent file with the same filename are in that directory so I have no idea what the problem is.
Can someone help me with this, please?

Link to comment
  • 1 month later...

I'm still struggling with the same problem. I tried looking for an answer all over the internet with no luck. I was trying to mess around with the bsp file in Hex Editor, I noticed it is an RBSP file, so it makes sense that the error says it's not an IBSP file. In Hex Editor I changed it to IBSP, then tried again recompiling with -onlyents. I got a new error which says my IBSP file is version 1 not 47. So this is probably not the way I should do it. If anyone could help me with this, I would be very happy.

Link to comment
  • 1 month later...

I suggest you try entity modding with NetRadiant Custom - You'll have to add a custom compile command in the build menu options of Radiant to add the ability to entitymod from that menu.

It seems your setup is calling q3map2 with too little information - usually GTK Radiant and NetRadiant Custom have the full paths to the games and q3map2 to call compiling / decompiling. It also supplies the q3map2 command line with some additional information, such as the gameprofile to use. I suspect you don't tell it which profile to use and thus it assumes you're trying to compile / entitymod for the default Quake 3 format which is IBSP. While I see some of that in the scripts posted in the tutorials you linked, maybe that's a start to verify you're doing everything correctly.

Link to comment

Thanks for the tip!

I finally managed to make it work! Turned out, I made more than one mistake. First, I don't know how it happened, but I had a GTK Radiant version which didn't even support Outcast and Academy. Now I have one that does. Second, I just realised I messed up saving the .ent file properly. It was "filename.ent.txt". Basically it was a standard text file with .ent considered as part of the filename. But my Windows only showed "filename.ent" so I thought I did it right.

I can't thank you enough for pointing to the right direction! 🙂

After months of failures I can finally make progress. 😄

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...