Jump to content

Game freezes at map loading.

Recommended Posts

I have a set of various mods that i assembled for my personal use. Everything seems to be working corectly, but recently i have encountered a very weird bug. The game freezes when you loading a specific maps. In my case it's vjun3, yavin1 and a map from a mod - spaseport. The game just frezez during the finale stage of loading. There is no error mesage, no errors in the console either. If you try to load another map with a console comand at this point you will get repeting "max_packet_usercmds" message in console. 

If you remove some of pk3, and load map again it will work fine. If you save in the begining, place pk3 that you removed, and load the save, everything will work fine. Its the same map, and the same stage in the level. But if you load it "from scratch" it frezes the game.

One time, map has loaded, but then it has error in the console saying that it cant find animation file for player. And player was invisible. That was weird. 

Mods I use, add models, modify npcs and saber files, also some effects. I grouped mods into several pk3. Removing the one with imperials is fixing problems for yavin1 and vjun3. Removing the one with dark jedis is fixing problems for spaceport map. I cant figurate what causing this problems. What is insane is that i tried combining pk3 and placed all characters in one pk3. Then other pk3 neded to be remove to fix problems. The pk3 with the weapons. I guess i hit some sort of limit thats within JKA but i dont know what limit is that.

There is little to no new npcs in mods i use. Maybe JKA has a limit of sab files? Or a limit of models that can be in the model directory? Or a limit of pk3? Or a limit of files game can load? Or a limit of files game can load ontop of preexisting? I have no idea what causing the problems and that's really driving crazy.

Can somebody give me a hint, what might cause those problems? 


Here is the pk3 i use, if somebody wants to look at them


Link to comment

Guys, please somebody tell me what kind of limitation does JKA have? I know it has limit of npc quantity, limit of vertex per mesh. Does it have limit of different models per map? What other limits does it have? Does it have limit of sabers quantity? 
What issue can cause problems on one map, but work fine for all the other? Considering that there is no problem with the map itself. It works fine without additional mods.

Thats just insane. I edit the cultists_saber npc, set their sabers to "reborn" and the map loads properly. I edit this npc again, and set their saber to saber from my mod, and the map freezzes when you trying to load. The point is, that this new saber's model is only like 100 polygons bigger than reborn saber. They both have small textures, like 256x256. But new one have a 3 texture in it. One 256x256 and two 128x128.

I noticed some similarities between all maps that freezes the game on load. Its yavin 1, vjun 3 and map "operation spaceport" (on which you fight both imperials and thugs). All those maps have many different characters, that uses diffirent models. Maybe this can cause problems, i thought. I tried to test this theory. And the results is weird again. For example if i give all cultists npc, stormtrooper's model, that will solve the problem, and map loads fine. But givin them human merc's model, or trandoshan's model dont solve problem. By the way I use dt's stormtroopers so they have more polys than vanila JKA human mercs and trandoshans.

I would really apreciate if someone can give me a hint. Just shared an information about possible JKA limitation or things that can cause problems.

Link to comment

Thanks for the reply. 
I just tested all this with latest OJP build, and game still freezes on load on those specific maps.

Anyway I play JKA on android (using Jedi Academy Touch) so unfortunately I cannot use OJP, as far as i know. Anyway I tested this issue on both android and pc. So that bug is not android specific.

By the way, If anyone knows a way to run OJP on android plese tell me.

Link to comment

Jedi Academy Touch which is no longer supported/updated.

That being said unless I am mistaken JKA Touch uses openjk (although probably an older version). That's no doubt how the original dev got jedi academy to run on android which is basically linux.

try typing /developer 1    in console and see if that gives any warnings.

If I get time I'll download the pk3s and have a look myself.


Link to comment
7 hours ago, Bubbles said:

That being said unless I am mistaken JKA Touch uses openjk (although probably an older version). That's no doubt how the original dev got jedi academy to run on android which is basically linux.

That is sounds right. 

Anyway. In developer mode console gives this repeating message

CL packet loopback: disconnected


Any clues what that means? 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...