Jump to content

RGB saber color not displaying


Recommended Posts

As stated by the topic name - none of the RGB color effects are displaying.

In the saber menu the RGB works, but when I use the saber on the map, only the white 'cores' are displaying.

It's not a graphics card issue, becuase they worked in the past, and it's not the settings, because I maxed 'em.

Any ideas?

Link to comment

What is the output of: /which cgamex86.dll (assuming windows)

Do you also have cl_assets.pk3?

What is the value of cp_sbRGB1 when you're playing on a server?

Is it a JA+(+) server?

good set of questions, but frankly, I have no idea :shrug:

I don't have cl_assets.pk3, I installed JA++ without JA+, could that be the reason? :huh:

I think it is a JA++ server...I mean, I am playing 'offline' with bots

Link to comment

You need cl_assets.pk3 for the images. JA+ is irrelevant, and should not be used.

If you're playing "offline" you'll also need the server binaries for it to be a JA++ server

ok, so where do I get cl_assets.pk3? also, what images are we talking about exactly?

I originally downloaded both client and server files, but the game would crash on custom maps, so I deleted the server files

Link to comment

From the JA++ download page, select client/server, your OS (windows/mac/linux) and CPU architecture (32/64 bit), then download all of those files.

cl_assets.pk3 is from the "Assets" download link.

From the JA++ download page, select client/server, your OS (windows/mac/linux) and CPU architecture (32/64 bit), then download all of those files.

cl_assets.pk3 is from the "Assets" download link.


...EDIT: Ohgod the forums have broken my post ;_;

Zeros is right, you can verify them by typing them into the console, when you're connected to a server/in game

Link to comment

Ok, so I typed 'em in. Here's what I got: "cp_sbrgb1" is "" default:"0". Tried switching it to 1, but other than saying "cp_sbrgb1" is "1", it didn't change anything.

It didn't react to "/which cgamesx86.dll". First it said "unknown cmd which", and then treated it as a simple "talk" message when I typed it in without "/which".


Literally type them both into the console and see if anything happens.

Zeros is right, you can verify them by typing them into the console, when you're connected to a server/in game


Link to comment

Unknown cmd which means you're using jamp rather than OpenJK same goes for treating it as chat without the /.


Shouldn't matter in general as to why your issue is happening, just mentioning that those changes are specific to OpenJK.

Link to comment

Unknown cmd which means you're using jamp rather than OpenJK same goes for treating it as chat without the /.


Shouldn't matter in general as to why your issue is happening, just mentioning that those changes are specific to OpenJK.

but why? I have openjk installed :huh:

also, if that's not the reason, what is?

Link to comment

Ok, so I created a desktop shortcut for OpenJK, added the +set fs_game "japlus" to the target box, but when I tried launching the game, I got an error reading:

GetGameAPI failed on uix86.dll

The crash log was written C:\Users\George\Documents\My Games\OpenJK\crashlog-2016-04-12_19-26-13.txt

And here's what the crashlog reads:

OpenJK-MP: v1.0.1.0 win_msvc-x86 Mar 25 2016
----- FS_Startup -----
Current search path:
C:\Users\George\Documents\My Games\OpenJK\japlus
D:\JKA\GameData\japlus\sh_lua.pk3 (6 files)
D:\JKA\GameData\japlus\sh_animations.pk3 (3 files)
D:\JKA\GameData\japlus\cl_bins_win32.pk3 (2 files)
D:\JKA\GameData\japlus\cl_assets.pk3 (52 files)
C:\Users\George\Documents\My Games\OpenJK\base
D:\JKA\GameData\base\zzz_E11.pk3 (21 files)
D:\JKA\GameData\base\Zeoskin.pk3 (57 files)
D:\JKA\GameData\base\Zabrak.pk3 (34 files)
D:\JKA\GameData\base\z-grade_staffanims.pk3 (5 files)
D:\JKA\GameData\base\vanilla clothes addon.pk3 (84 files)
D:\JKA\GameData\base\Vader_statue_Duel_map.pk3 (18 files)
D:\JKA\GameData\base\Twi'lek (Battlefront).pk3 (37 files)
D:\JKA\GameData\base\technicolor_shield.pk3 (5 files)
D:\JKA\GameData\base\Taris_RP.pk3 (445 files)
D:\JKA\GameData\base\SWTOR_IconComplete.pk3 (3 files)
D:\JKA\GameData\base\soviet_flag.pk3 (5 files)
D:\JKA\GameData\base\SnowConsole.pk3 (6 files)
D:\JKA\GameData\base\SilentMenus.pk3 (40 files)
D:\JKA\GameData\base\siege_destroyer.pk3 (115 files)
D:\JKA\GameData\base\sabercrystalsicons.pk3 (9 files)
D:\JKA\GameData\base\Rodian Heavy Defender.pk3 (34 files)
D:\JKA\GameData\base\PSKEG5.pk3 (122 files)
D:\JKA\GameData\base\Proxy.pk3 (73 files)
D:\JKA\GameData\base\opresshilt.pk3 (13 files)
D:\JKA\GameData\base\NEW_CTF_FLAG_ICONS.pk3 (8 files)
D:\JKA\GameData\base\momfruitbeef.pk3 (100 files)
D:\JKA\GameData\base\maul.pk3 (19 files)
D:\JKA\GameData\base\Mark Pride.pk3 (84 files)
D:\JKA\GameData\base\Map_!SoS!_Underground.pk3 (31 files)
D:\JKA\GameData\base\landing_zone_17.pk3 (167 files)
D:\JKA\GameData\base\korriban_sith_academy_v1.0.pk3 (32 files)
D:\JKA\GameData\base\korribanbeta.pk3 (154 files)
D:\JKA\GameData\base\Korriban Academy.pk3 (119 files)
D:\JKA\GameData\base\klavika.pk3 (74 files)
D:\JKA\GameData\base\jka_sabers.pk3 (182 files)
D:\JKA\GameData\base\jedi rax.pk3 (8 files)
D:\JKA\GameData\base\illutec_desert_hoth.pk3 (27 files)
D:\JKA\GameData\base\hudfallout_jka.pk3 (21 files)
D:\JKA\GameData\base\HiddenIcons.pk3 (52 files)
D:\JKA\GameData\base\friend.pk3 (98 files)
D:\JKA\GameData\base\duel_chess.pk3 (27 files)
D:\JKA\GameData\base\DT_Maul.pk3 (79 files)
D:\JKA\GameData\base\dl_jedirebornv.2.pk3 (47 files)
D:\JKA\GameData\base\darksaber.pk3 (63 files)
D:\JKA\GameData\base\cybernetic_maul.pk3 (52 files)
D:\JKA\GameData\base\bonus.pk3 (80 files)
D:\JKA\GameData\base\Better caps.pk3 (4 files)
D:\JKA\GameData\base\assets3.pk3 (16 files)
D:\JKA\GameData\base\assets2.pk3 (62 files)
D:\JKA\GameData\base\assets1.pk3 (8320 files)
D:\JKA\GameData\base\assets0.pk3 (15346 files)
D:\JKA\GameData\base\ancient_outpost.pk3 (128 files)
D:\JKA\GameData\base\(x-sith)TEMPLE_v4.pk3 (122 files)

26711 files in pk3 files
execing mpdefault.cfg
execing openjk.cfg
couldn't exec autoexec.cfg
----- Initializing Renderer ----
Trying to load "rd-vanilla_x86.dll" from "D:\JKA\GameData"...
QKEY found.
SDL using driver "windows"
Initializing display
Display aspect: 1.779
...setting mode 4: 800 600
Using 24 color bits, 24 depth, 8 stencil display.
Available modes: '1280x720 1366x768 1360x768 1280x768 320x200 640x400 1280x600 320x240 400x300 512x384 640x480 800x600 1024x768'
GL_RENDERER: Intel® HD Graphics
Initializing OpenGL extensions
...GL_EXT_texture_compression_s3tc available
...no tc preference specified
.....using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_env_add
...GL_EXT_texture_filter_anisotropic available
...using GL_EXT_texture_filter_anisotropic
...using GL_EXT_texture_edge_clamp
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...GL_NV_register_combiners not found

GL_RENDERER: Intel® HD Graphics
GL_VERSION: 3.1.0 - Build
GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_EXT_texture_swizzle GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_EXT_texture_snorm GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_INTEL_map_texture GL_ARB_vertex_array_object GL_ARB_provoking_vertex

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(8-bits)
MODE: 4, 800 x 600 windowed hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: single glDrawElements
picmip: 0
texture bits: 0
lightmap texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
compressed textures: enabled
compressed lightmaps: disabled
texture compression method: GL_EXT_texture_compression_s3tc
anisotropic filtering: enabled  (16 of 16)
Dynamic Glow: disabled

------- sound initialization -------
SDL audio driver is "xaudio2".
  Format:   AUDIO_S16LSB
  Freq:     44100
  Samples:  1024
  Channels: 2
Starting SDL audio callback...
SDL audio initialized.
----- Sound Info -----
    1 stereo
32768 samples
   16 samplebits
    1 submission_chunk
44100 speed
0x72c8048 dma buffer
No background file.

--- ambient sound initialization ---
Sound memory manager started
VM_Create: uix86.dll succeeded
Mismatched UI_API_VERSION: expected 2, got 3
Closing SDL audio device...
SDL audio device shut down.
GetGameAPI failed on uix86.dll

So apparently it's something with UI_API_VERSION or the SDL audio device.

Based on what you wrote here, I should try deleting .dll's and openjk.pk3. I'll go with deleting openjk.pk3 first, then I'll start deleting .dll's - HEADS WILL ROLL!!!

Just a little joke. If none of these work, I guess I'll try reinstalling OpenJK.

Will update you's as it goes.

Nope, didn't work. My "Documents" folder had no .dll's, so I deleted openjk.pk3 and openjk86.dll in the "Gamedata" folder, but still no juice. Guess I'll have to do a clean reinstall...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...