Jump to content
Tekkno

UV meshes and seams

Recommended Posts

Hi there, I've been trying (mostly through trial and error!) over the last few days to import a model into JKA. Every time I think I've understood what I'm doing, blender throws a new problem at me. That's been fine, I think I've worked out most of the problems - but now that I finally think I'm ready to export, it throws up "Could not load surface X (LOD 0) from Blender: UV seam found! Split meshes at UV seams?" - where "X" could be any part of the body. I've gone through some threads on similar problems on this forum, and they seemed to suggest separating off parts of the mesh and rejoining them, which I've done. I've gone through the UVs and removed all seams, and I've made sure that there are no bits of one mesh joined incorrectly to another.

I'm at my wits end on this one, and my google-fu has failed me on fixing the issue. So....anyone able to help a complete noob at this out? Thanks!

 

Share this post


Link to post

The solution here would be to go through the UVmap of the mesh which causes the error, then tick the option to "Keep UV and edit mode mesh selection in sync" (left of the selection modes), select all the seams that make up the "islands" (the "perimeters" basically), then go back to 3D View and select Mesh -> Edges -> Edge split. That does exactly what the program asks you to do - splitting meshes at UV seams - and should fix the problem.

Share this post


Link to post

Thanks for your reply! I have done what you suggested, and now instead it's telling my that there's a vertex without UV coordinates - and if there is I can't damn well find it! I've done an 'a' select on the offending section of model and it doesn't show anything unassigned...

Honestly, with this being my first attempt I'm sure I've done something wrong somewhere - 90% of this has been a learning process, so I might start again. But if you have any suggestions before I do, I'd appreciate it 🙂

Share this post


Link to post

You can try selecting the mesh, entering Edit Mode, then Mesh -> Clean up -> Delete Loose ticking Vertices only. Not sure this will fix it though, but it might.

Tekkno likes this

Share this post


Link to post

Which version of the exporter are you using? There's a version that builds upon mine which works in newer Blender versions and removes the need to manually split meshes at UV seams.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...