Jump to content

Jedi Academy MP launcher for OS X 1.3

   (4 reviews)

1 Screenshot

About This File

Jedi Academy Multiplayer (and a few other Q3 engine games) don’t run on Mac Lion/Mountain Lion because of some OpenGL issues on ATI graphics cards.

JKJALaunch is a launcher for Jedi Academy Multiplayer that forces ATI FSAA off, allowing the game to run on Lion and Mountain Lion (but unfortunately not on Mavericks). It also allows you to specify command-line options and force 32-bit colour (as needed on certain graphics cards).

 

Hold Shift down at launch to bring up the options window, where you can choose the location of Jedi Academy Multiplayer and set the command-line options.

When you’re asked to find Jedi Academy MP, you can also select Jedi Academy, Jedi Knight II, Jedi Knight II MP and Wolfenstein ET.

The launcher works with the 1.0.1e for disc version multiplayer patch, digital download and Jedi Knight Gold edition (but not on Mavericks) for Mac.

 

New in 1.2!

 

The latest Steam and Mac App Store versions of Jedi Academy (Multiplayer) have a problem with connecting to servers which you do not have all .pk3s for. JKJALaunch now supports launching them (including on Mavericks) and fixes this. Only the Steam version supports command-line options.

If you bring up the options window by holding shift down at launch, you can check for updates by doing JKJALaunch->Check for updates… in the menu.

 

New in 1.3!

 

Custom master server support for Steam and Mac App Store versions of Jedi Academy (Multiplayer).

THIS FILE IS NOT MADE, DISTRIBUTED, OR SUPPORTED BY ACTIVISION, RAVEN SOFTWARE, OR LUCASARTS ENTERTAINMENT COMPANY LLC. ELEMENTS™ & © LUCASARTS ENTERTAINMENT COMPANY, LLC AND/OR ITS LICENSORS.


What's New in Version 1.3

Released

  • Custom master server support.
  • Better JK2 App Store and Steam support.
  • Added App Store and Steam version support.
  • Better support for multiple copies of launcher.
  • Sparkle support for updating.

User Feedback

Recommended Comments

I can confirm this jewel works on 10.10 OSX Yosemite, and launches my Steam version just fine. :) Thanks for a wonderful Launcher!

Circa likes this
Link to comment

hey, I tried this tutorial and it worked. but then all of a sudden it stopped working and the problem appeared again - what do I do?...

Link to comment

At my friends house i tried running MB2, but when i ran Jedi Academy MP Launcher it said that the variant isn't correct and i couldn't find the location.

Link to comment

hey, I tried this tutorial and it worked. but then all of a sudden it stopped working and the problem appeared again - what do I do?...

Same problem, it was working fine but now it's not working.

Link to comment

I need help. I've been trying to use this launcher to play movie battles 2. It doesn't seem to working for whatever reason. I have put the correct location of Jedi Academy, but it still say's "Current Version Selected: Invalid". I've also put +set fs_game MBII in the command line options. The 'OK' button is grayed out so I can't proceed further. I'm running macOS Sierra. Maybe the launcher just doesn't work on this version?

 

Link to comment

I need help. I've been trying to use this launcher to play movie battles 2. It doesn't seem to working for whatever reason. I have put the correct location of Jedi Academy, but it still say's "Current Version Selected: Invalid". I've also put +set fs_game MBII in the command line options. The 'OK' button is grayed out so I can't proceed further. I'm running macOS Sierra. Maybe the launcher just doesn't work on this version?

You have to use the MBII app to launch MBII, not this.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...