Jump to content

Windows vs Linux versions


Paullik74

Recommended Posts

Hi,

on Linux, I was able to set cg_fov 115 with r_mode -2 (1080p) on pure basejka servers. On Windows I'm not able to set this. How can I do that? I don't want to use something like cvar_unlocker. I just want enforce to load openjk library file before basejka dlls from assets, or something like that :D.

 

Any suggestions? :) Is it possible?

Link to comment

Depending on what version of OpenJK you have, the loading priority may be set different. Try either of the following. Make sure openjk.pk3 (containing cgamex86.dll, jampgamex86.dll, and uix86.dll) is located in:

 

1. GameData/OpenJK/

 

2. ~/Documents/My Games/OpenJK/base/ and ~/Documents/My Games/OpenJK/japlus/ (or any other MP mod if available).

 

I've found that the second method works better for me.

Link to comment

Depending on what version of OpenJK you have, ...

 

I have latest windows build from http://builds.openjk.org/. I was trying put newest openjk.pk3 from OpenJK folder (in OpenJK folder are still two pk3 files O:)) to homepath (My Games/OpenJK/base) and rename it to zzz-openjk.pk3, but still nothing.

 

 

The issue is related to base servers.

These servers don't have a copy of the linux binaries in order to verify they're "pure". Because of that, pure server checks only apply to retail JA DLLs on Windows.

 

So what if I rewrite DLLs in assets pk3s with DLLs from openjk.pk3? But same DLLs like in openjk.pk3 is in assets2 and assets3. Which one rewrite? It will help? I think I was trying something like that but then JKA was broken and everytime stopped working :D

Or... I don't know... compile linux versions of base/jampgamei386.so, uii386.so and cgamei386.so to *.dll? :D Or something like that? :D Sorry if it is absolutly wrong way. :D

Link to comment

...on pure basejka servers...

My bad. I missed that part. Pure servers are asking for the retail DLL, and the retail DLL does not support changing the field of view without cheats enabled, I think.

 

Is it possible?

So no, I don't think this is possible. OpenJK will default to the vanilla DLLs when joining a pure server, in order to keep you connected and playing, as far as I know. Otherwise the server would drop you for not being "pure".

 

And if I understand correctly, what @@Raz0r is saying is that when it happened in Linux that you could do this, that was an anomaly rather than the rule. The normal behaviour is that a pure server will force the client to revert to its retail library, otherwise it will drop the client.

Link to comment

You can with modified binaries of course but this is not a discussion for this topic or even valid for us to discuss.  Yes Linux does get around this but this is not the intention and there is no other way to support pure servers and have a Linux client to do this.  Official Windows versions will not be modified to circumvent it in any official capacity.

Cerez likes this
Link to comment

It doesn't matter whether you are on a pure server or not as to why the cvar does not work.

 

The reason it does not work is it is limited to 97 in basejka cgamex86.dll which is being used on the pure servers. End o story.  Get your rubbish admins to stop using pure if its such a concern as pure doesn't stop much to those who can do anything about it coding wise.

Cerez, eezstreet and Smoo like this
Link to comment

I'm not blaming anyone, I'm saying that its flawed reasoning to still abide by the fact that pure servers do anything and hence rubbish admins who think it does.  I could connect to a pure base server with JA++ running in base if I wanted to, just is slightly more difficult than other things :\

Cerez and Paullik74 like this
Link to comment

I just set the cmds in autoexec.cfg or in this case openjkautoexec.cfg i think and it loads when you first join a server. Though it resets when map changes or restarts or when joinijg another server

Its still autoexec.cfg and only works on initial startup.

Smoo likes this
Link to comment

What happens on your rig when you try to set the custom fov, @@Paullik74? cg_fov is a client-side setting, and it shouldn't matter whether you're on a pure server or not.

Sorry for late answer. Like ensiform said, when I set higher cg_fov then 97 (on pure servers), nothing happen, fov is stuck on 97. I was interested in that because I want to use 1920x1080 resolution and with that is cg_fov 97 really low. But how I look, I'm out of luck. I tought it would be like that.

 

I'm not blaming anyone, I'm saying that its flawed reasoning to still abide by the fact that pure servers do anything and hence rubbish admins who think it does.  I could connect to a pure base server with JA++ running in base if I wanted to, just is slightly more difficult than other things :\

+1. I'm admin of few servers and the only reason why I set on base servers sv_pure 1 is because when I set to 0, everybody cry it isn't pure :D. On the other hand, without pure, would appear lot of players with edited pk3s and libraries for ultra imba skillah :/ :D.

Link to comment

Because your playerbase doesn't know any better either.  Yes of course, but simple google search suggests they already can get around it but I won't say how.  Base servers also should not be explicitly set to fs_game Base either :P

 

OpenJK's cgame also does have the aspect correct fov too not just allowing you to set the value higher.

Smoo, Cerez and eezstreet like this
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...