Jump to content

Trying to set Blender back up and I've encountered a weird glitch

Go to solution Solved by mrwonko,

Recommended Posts

So I managed to get the damn plugin  working again after having to edit some of the .py files to make it work with Blender 3.2. Once I got everything set up, and remembered how it's supposed to read in the file format, I started getting a weird error every time I wanted to import a model. Here's what it said


Python: Traceback (most recent call last):
  File "/home/please/.var/app/org.blender.Blender/config/blender/3.2/scripts/addons/jediacademy/JAG2Operators.py", line 91, in execute
    success, message = scene.saveToBlender(scale, skin, self.guessTextures, self.skeletonFixes)
  File "/home/please/.var/app/org.blender.Blender/config/blender/3.2/scripts/addons/jediacademy/JAG2Scene.py", line 139, in saveToBlender
    success, message = self.glm.saveToBlender(self.basepath, self.gla, scene_root, skin_rel, guessTextures)
  File "/home/please/.var/app/org.blender.Blender/config/blender/3.2/scripts/addons/jediacademy/JAG2GLM.py", line 1050, in saveToBlender
  File "/home/please/.var/app/org.blender.Blender/config/blender/3.2/scripts/addons/jediacademy/JAG2GLM.py", line 874, in saveToBlender
    LOD.saveToBlender(data, root)
  File "/home/please/.var/app/org.blender.Blender/config/blender/3.2/scripts/addons/jediacademy/JAG2GLM.py", line 805, in saveToBlender
    obj = surface.saveToBlender(data, self.level)
  File "/home/please/.var/app/org.blender.Blender/config/blender/3.2/scripts/addons/jediacademy/JAG2GLM.py", line 638, in saveToBlender
    bvert.normal = vert.normal
AttributeError: bpy_struct: attribute "normal" from "MeshVertex" is read-only


I genuinely cannot tell what this is trying to say to me. I think Blender is having trouble editing a file, but what that is has got me stumped. Maybe I'm just sleep deprived (I am), but this isn't making sense.

Link to comment

After spending quite a while working on this, and listening to some VERY LOUD people watching cable of all things, I have solved the issue.


See, the real problem here was I incorrectly installed Blender for Linux. I installed it from the online store that came with my distro, and not the command line. So in essence, this was more of a Linux noob problem rather than an issue with the actual Jedi Academy plugin.


The Plugin still required some editing in it's .py files to work on my version of Blender, but it's all fine right now 

Link to comment
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...