Jump to content

Getting "Assertion failed!" with my compiled files on modded maps/saves

Recommended Posts

Hello! Hope this is the correct area, it seemed most relevant to me. Recently I downloaded @@eezstreet 's AI Workshop mod. Only very recently have I first delved into building/compiling my own .dlls and .exes, with the desire to edit code in the future. Eezstreet offered the source code within this download so I figured it was the perfect time! Before making any changes at all, I wanted to simply recompile the proper files just to see if it would turn out fine before I waste time changing any code. Well as it turns out its a good thing I did this test, as I have indeed been coming across problems.... but it isn't just this mod alone, I later learned my issues happen with all builds I do. Whether its OpenJK vanilla, OpenJK custom, other people's mods, etc.


As for the specific issue, I'll now elaborate on what the exact problem is with this error. So with the AI Workshop mod, it works perfectly fine... all maps and savegames load up with no issues at all, and the mod itself is working properly! Anyways I went ahead and recompiled the given source code using Visual Studio Community 2017, and yes I made sure it was set to "Release" build and it is not set to "Debug" mode (a common mistake I've read about).


When I load up my saved games, I suddenly get this error every single time:



When I click "Ignore" then it goes through about 3 or 4 similar errors before giving up and crashing. First thing I found odd was, again, I made absolutely no changes whatsoever. I compiled "jagamex86.dll", "openjk_sp.x86.exe", and "rdsp-vanilla_x86.dll". Next I tried to mix it up a bit, compiling only 1 of the files or 2 of them but same result no matter the combination. So then the next thing I thought of, maybe it doesn't like my save files? So I tried to load up a map instead (yavin1b specifically) and..... it worked! At least at first... because next I tried to load a modded map and I get this same error. Pretty much any map that isn't vanilla Jedi Academy gives this error.


Here is the line its pointing towards, within code/game/g_navigator.cpp, but I'm not sure whats wrong with it lol!

        // Try It
        if (!MoveTrace(Start, Stop, Mins, Maxs, 0, true, false))
            assert("ERROR: Nav in solid!"==0);
            gi.Printf( S_COLOR_RED"ERROR: Nav(%d) in solid: %s@%s\n", type, pointName, mLocStringA);
            delayedShutDown = level.time + 100;

I'd like to compile something that runs at least 90% properly, know what I mean? Haha! Eezstreet's download works perfectly fine on modded maps and savegames, so I don't see why it shouldn't work when I build it myself without making any changes.... therefore I'm sure there must be something I'm doing wrong. The next question is.... what am I doing wrong? Its very frustrating because I feel that I'm so close to being able to edit certain content, yet this is something now preventing me from continuing. I want to edit .dlls and such so that I can tweak the game for my own personal tastes; additional force powers/weapons, more lightsaber color choices, RGB lightsabers as well, increased cap for the dismembering limit, increased NPCs/vehicles, menu editing, and much more. Or perhaps just do experiments with the game and come up with something I wouldn't have thought of before! So yeah I really hope someone with more knowledge than me can shed some light on this! I'd really appreciate it! Thanks for reading.

Link to comment

Hmm I see, is there another possible way that something could become debugged unintentionally? Or a way to determine if I'm using debugged content?


Also here is proof, lol.  And when I build it I select "Build>Build Solution".




I've also made absolutely sure that there are definitely no other .dlls or mods interfering with this... whether they are within the "Base" folder or "OpenJK", and I've also experimented with placing jagamex86.dll in multiple areas just in case.


Btw, also using Windows 7. Forgot that info heh

Link to comment

God damn it, I f**king knew it. I knew it was going to be something really stupid and small I had overlooked.... so yes it was debugged, and here is why. So I completely forgot (and didn't even notice at first) that the build created a completely different output folder separate from the debug builds. I kept taking my compiled content out of the debug folder instead of the release folder lol... I also just now went into the game just in case and yup everything works perfectly!


Like... I'm sure I would have found out eventually but I really really hate spending a long ass time on an issue trying to figure it out by myself (so I can learn better) until I eventually decide to ask someone for help, and then I find out the solution by myself shortly afterwards... that always happens it seems, lol. I think one of my main problems is that I focus way too much on details and way too much on advanced things when it comes to modding content or figuring stuff out. As a result I sometimes forget to look at the bigger picture! Oh well... I really appreciate the help, as well as any other help I would have gotten if I hadn't found this out just now lmao...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...