Jump to content

Certain events not loading after death SP openjk


Recommended Posts

First I would like to say thank you all for your amazing work! I just Installed Openjk last night, what a nostalgia trip.


Well I was trying the singleplayer version of open jk 64bit on linux mint 17.3 64bit, and if I die and load the checkpoint or save certain events are not reloaded and I cannot continue the game.


For example on yavin 4 If I die and load up a save I cannot cut the tree also scripted ai events will not load, I tested this many times. The only thing I could do was to exit the game completely and restart. 


Anyone else having this issues? is this a linux specific issue?


Thanks in advance for your time.

Link to comment

These are all new saves, seems to be related to this issue on https://github.com/JACoders/OpenJK/issues/780 not the different arch saves of course.

I would have to completely quit the game to get the triggers to load, so I did some more digging and I found this workaround https://github.com/ioquake/jedi-academy/commit/d6bc68d63259234b83ceaec9464cebd2aa188374

So I did that and built openjk and it is now functioning. Maybe has to do with how g++ treats inline functions? I saw a few other linux users having the same issues as well. What compiler are the windows builds using? If it builds on windows with the workaround with no issues.. maybe make a pull request?


I'm still a novice c++ programmer so if someone can chime in on this.

Link to comment

Windows uses Visual C++ of course so not gcc/g++.


Windows can use a port of gcc, but anyway that is besides the point. The windows build seems to not have the issue and only the linux build has the problem. I think the problem is the way g++ handles the inline fucntions, I tried adding the inline tag to the function declaration inside the class and it fixed the issue.

Link to comment

@@gort818 I've commented on your GitHub issue. I'll quote it here for convenience:


I believe this is a duplicate.of #257.and #295. I fixed it in e8fc637 and 96d335c, but it was potentially broken again in bace05c when the -fvisibility=hidden -fvisibility-inlines-hidden were removed for GCC builds...


An issue with your pull request is that it doesn't solve the underlying problem.

The comment has links to each of the commits I've mentioned :)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...