Jump to content

Porting SWTOR Models into Jedi Academy / NOT WORKING ANYMORE / HELP

Go to solution Solved by DarthValeria,

Recommended Posts

Greetings, probably some of you saw what I or others did for modding Jedi Academy

Like porting characters from the game and converting them into JKA for example

And we were using Ninja 1.7.1 to port this

But unfortunately 1.7.1 doesn't work anymore, I mean it ports characters into million pieces, terrible quality and incomplete


I got Ninja Ripper 2.0.11 and tried again but it causes SWTOR to crash all the time


This new Ninja Ripper uses both d3d files and dgVooDoo2

And it seems its dgvoodoo2 causes game to crash or stop working or not responding


I wonder did anyone tried new Ninja Ripper and port player characters from SWTOR?

Or managed to port characters without crashing or something


I would like to know and if there is a way, please let me know

Droidy365 likes this
Link to comment
  • DarthValeria changed the title to Porting SWTOR Models into Jedi Academy / NOT WORKING ANYMORE / HELP
  • 2 weeks later...
  • Solution


As I mentioned, newer versions of Ninja Ripper doesn't work in SWTOR

But I decided to test old version again


Then I realized that Ninja Ripper doesn't work only on my own characters

But it works on other player characters or npcs


So we have hope

May the Force be with us all

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...