Jump to content
Sign in to follow this  
ronaldo_chips

Help for a Mac user?

Recommended Posts

Hi there. I've followed the instructions in the install guide on a mac for the steam version.

The base folder is empty of other mods, but every time I run singleplayer it comes up with an error about my OS version compatibility. 

I'm running OS X El Capitan 10.11.3. Is this a problem for the mod to run? If not, could there be another reason for its failure?

Thanks in advance for any help you can give me.

Share this post


Link to post

Hi there. I've followed the instructions in the install guide on a mac for the steam version.

The base folder is empty of other mods, but every time I run singleplayer it comes up with an error about my OS version compatibility. 

I'm running OS X El Capitan 10.11.3. Is this a problem for the mod to run? If not, could there be another reason for its failure?

Thanks in advance for any help you can give me.

Do you have a picture of your error message? Have you tried the optional step? May you send me a picture of your contents folder? Have you installed homebrew and sdl2? 

Share this post


Link to post

Can you be more specific about your error? 

Sure. I followed the instructions on the Mac Install Guide. Put the KotF file into the contents folder. Then put the KotF 2.1 SP and KotF 2.1 MP files in the contents folder as well. I've also gone into the terminal, downloaded homebrew and SDL2.

 

When I try and open Singleplayer from the application in the contents, it comes up with the error "KotF_2,1_SP.x86_64 cannot be opened because of a problem".

 

Below that it says "Check with the developer to make sure KotF_2.1_SP.x86_64 works with this version of OS X. You may need to reinstall the application. Be sure to install any available updates for the application and OS X". This is why I mentioned my OS version.

 

I've also tried unloading the pk3 files into the base folder, which works when I open Jedi Academy on Steam, but this only gets me to the main menu. When I try and press new game, the music loops and nothing happens. I've also tried putting all pk3 files in the Contents folder, without being in the KotF folder, which also doesnt work.

Share this post


Link to post

Also, just tried the optional step. It failed and came up with this:
 
dyld: Library not loaded: @rpath/SDL2.framework/Versions/A/SDL2
  Referenced from: /Users/will/Library/Application Support/Steam/steamapps/common/Jedi Academy/SWJKJA.app/Contents/KotF_2.1_SP.x86_64.app/Contents/MacOS/KotF_2.1_SP.x86_64
  Reason: image not found
Trace/BPT trap: 5

 

 https://i.imgur.com/De6KJsG.png
Also attached is a photo of my contents folder.

Share this post


Link to post

Also, just tried the optional step. It failed and came up with this:

 

dyld: Library not loaded: @rpath/SDL2.framework/Versions/A/SDL2

  Referenced from: /Users/will/Library/Application Support/Steam/steamapps/common/Jedi Academy/SWJKJA.app/Contents/KotF_2.1_SP.x86_64.app/Contents/MacOS/KotF_2.1_SP.x86_64

  Reason: image not found

Trace/BPT trap: 5

 

 https://i.imgur.com/De6KJsG.png

Also attached is a photo of my contents folder.

Ok, I think I know the problem. Go to finder and press command + shift + g. You want to type your username, so my username is jd, so I would type:

 

/Users/jd/Library/

 

 

Inside Library create a folder called Frameworks. Next go to https://www.libsdl.org/download-2.0.php and download SDL2-2.0.7.dmg. Take the SDL2.framework file and put it into the Frameworks folder. I think that should work. 

 

 

Don't put anything in your base. All you should have is KotF 2.1 SP, KotF 2.1 MP, and the KotF folder. 

Odeyseis likes this

Share this post


Link to post

Hey guys, bringing this topic back from the dead. I originally had the same problem here and followed all the steps above.

When I booted it up however, the launcher cant seem to find the config file because there is no file name jaconfig.cfg. I have the game on steam and have tried starting up the game through both steam and the desktop shortcut (didn't know if that makes a difference). I have started new games saved and quit. I feel like I have tried everything but I cannot get the jaconfig file to appear.

 

Any suggestions?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...