Jump to content

Search the Community

Showing results for tags 'mapping'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Interviews
  • Site news
  • Community News

Categories

  • Coding
  • Console Commands & Cvars
  • Errors & Problems
  • Gameplay
  • General Modding
  • Mapping
  • Media
  • Modelling
  • Server Management
  • Skinning
  • Specific Mods

Forums

  • Jedi Knight Modding
    • General Modding Discussions
    • WIPs, Teasers & Releases
    • Modding Assistance
    • Coding and Scripts
    • Mod Requests & Suggestions
  • Jedi Knight Discussion
    • Jedi Knight General Discussions
    • Jedi Knight Tech Support
    • Advertisements
    • Tutorials
  • Mod Project Forums
    • OpenJK
    • Galactic Legacy
    • Jedi Knight Galaxies
    • Dark Forces II Mod
    • JA++
    • Jedi Academy Moviemaker's Edition
    • Star Wars: Warzone
    • The Dark Pastime
    • Epic Challenge Mods
    • Jedi Academy: Enhanced
    • Inactive Mods
  • JKHub Community
    • News
    • Art, Media & Technology
    • Star Wars Franchise Discussions

Categories

  • Jedi Academy
    • Art Work
    • Audio
    • Code Mods
    • Configuration Files
    • Cosmetic Mods
    • Guns & Explosives
    • Lightsabers & Melee
    • Maps
    • Media
    • Mod Bundles
    • NPCs
    • Official Releases
    • Prefabs
    • Player Models
    • Skins
    • Single Player
    • Utilities
    • Vehicles
  • Jedi Outcast
    • Audio
    • Code Mods
    • Configuration Files
    • Cosmetic Mods
    • Guns & Explosives
    • Lightsabers & Melee
    • Maps
    • Media
    • Mod Bundles
    • Official Releases
    • Player Models
    • Single Player
    • Skins
    • Utilities
    • Vehicles
  • Both Games/Other
    • Utilities
  • Contest Entries

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Email


Website


Steam


Xbox Live


PSN


Discord


Origin (EA)


Twitter


YouTube


Other


Location


Interests


Operating System


Current Clan


Clan Website

  1. Looks like I can't realy turn off soundSet. I tried both target_speaker and empty(empty .fx file) fx_runner - both are broken. I tried to turn it off with targeting it, with target_deactivate and with script "remove ( "GenSound" );" Any ideas?
  2. Short: Does GtkRadiant work with Windows 10 correctly? I'm getting the same error regardles of what map file I load: "Error opening E:/JK_Modding/Projects/Space/space.srf: No such file or directory" I've used GtkRadiant for JA before, but that was years ago. That is the only error message I am seeing. Long: After ~5 years, I'm trying to get back into Jedi Academy modding. OpenJK seems mature and stable, I've got a much more solid grasp of C++ than when I first dabbled in code mods, and I have finally talked a friend into playing. I'm trying to set up GtkRadiant so I can make a simple testing map so I can mess around with the spacecraft vehicles. I downloaded the latest build (1.6.5-20170820), extracted it, and pointed it to a copy of OpenJK with just the default PK3s. I built a very simple map (large box with a player spawnpoint entity) and went to compile a BSP and get testing. No matter what I do, though, I cannot compile a BSP. I get the following: === running BSP command === "E:/JK_Modding/Tools/GtkRadiant-1.6.5-20170820/q3map2" -v -connect 127.0.0.1:39000 -game ja -fs_basepath "E:/JK_Modding/Game/OpenJK/" -light -faster "E:/JK_Modding/Projects/Space/space.map" Connected. 8 threads Q3Map - v1.0r (c) 1999 Id Software Inc. Q3Map (ydnar) - v2.5.17 GtkRadiant - v1.6.5 Aug 20 2017 17:29:27 We're still here --- InitPaths --- VFS Init: E:/JK_Modding/Game/OpenJK//base/ --- Light --- Faster mode enabled Map has shader script E:/JK_Modding/Projects/Space/../shaders/q3map2_space.shader entering shaders/shaderlist.txt entering shaders/bespin.shader...and it goes through all the shaders... entering shaders/wedge.shader entering shaders/yavin.shader 2215 shaderInfo Loading E:/JK_Modding/Projects/Space/space.bsp Loading E:/JK_Modding/Projects/Space/space.srf ************ ERROR ************ Error opening E:/JK_Modding/Projects/Space/space.srf: No such file or directory Disconnecting Connection closed.I don't think I've encountered this issue before. I have tried running Radiant as an Administrator, I made sure file permissions for the directory were set correctly, and I'm not really sure what else to try.
  3. So, I opened in GTKRadiant for the first time in goodness knows how long so that I could crack on with Yavin IV. Before starting, I decided to compile the map to refresh my memory of where I was up to, then this came up: Naturally, I searched for the error with Google: I'm looking for help. I've attempted following the instructions at the top and combed through the map trying to sort this out to no avail. The map still compiles eventually and aesthetically, looks the same as ever, but it takes a really long time about it now. Is there anyone here who has encountered this problem before? What did you do to fix it? Any help would be greatly appreciated.
  4. So I've made a big ass door that I'd like to remain opened once used by trigger_once (not pressed as a button). I've been experimenting with "Delay" and "Wait" values, but it seems it won't do the trick, the door keeps closing. One other thing that I noticed is if you use trigger_once or trigger_multiple by pressing it to open a door with a Wait of 0, it stays opened or closed. It depends on how you press it. I wanted to do the same thing for non-button pressing trigger_once, but I guess that's not it. Suggestions/Examples?
  5. Hi! I have about nine identical doorways and this is the only one with this issue. It's not duplicate brushes occupying the same space and the surface you're looking at isn't caulked or anything, it has a proper texture. Does anyone know why this thing keeps persisting?
  6. In one of the rooms (I'm sure you can guess which one) I have two NPCs practising their lightsaber techniques against one another. When I walk around the temple, I can hear their occasional taunt, jump and clash and grunt. The area is completely sealed with an area portal, so I'm not sure why this is. Are the sounds global or something? I can hear them from the other side of the map. If that's the case, is there anything I can do about it? I have this problem on the original Yavin Temple in Jedi Outcast too. Is the only solution to rig it in such a way that they despawn/spawn when you leave and enter the said area?
  7. While in the process of populating Yavin IV with NPCs, I came across this conundrum: They'll quite cheerfully slash at one another until they're at a great distance or the pillar obstructs their vision of one another. I added //(BHVD) set ( /*@SET_TYPES*/ "SET_LOOK_FOR_ENEMIES", "true" ); and that seems to have overcome the distance issue, but not the line of sight one. I assume this is something that waypoints help with. Does anyone happen to have any advice on how this works? EDIT: Any recommendations on how to keep them quiet would be good too. They already have... //(BHVD) set ( /*@SET_TYPES*/ "SET_NO_COMBAT_TALK", /*@BOOL_TYPES*/ "true" ); //(BHVD) set ( /*@SET_TYPES*/ "SET_IGNOREPAIN", /*@BOOL_TYPES*/ "true" );//(BHVD) set ( /*@SET_TYPES*/ "SET_NO_ALERT_TALK", /*@BOOL_TYPES*/ "true" ); They don't complain when they wallop each other, but there's only so many times you can hear the words "Let the Force flow through you!"
  8. In an attempt to make the Yavin Temple a bit more lively, I've put two NPCs in front of the movable blocks. The NPCs push the blocks just fine, but they cannot pull them back. Their Force Pull level is set to level 3. In the video, mine is set to level 1. Does anyone have any suggestions on how to amend this problem? https://youtu.be/2GkXKr82XTU
  9. This is a request for some modding assistance.. And is mainly directed at any and all coders, mappers and anyone who's worked on designing maps for Single Player. Myself and @@Tompa9 are working on the "MD2 Remastered" mod, found here: https://jkhub.org/topic/9062-star-wars-movie-duels-ii-remastered-current-wip/ However, we're currently looking into updating the music tracks that were used in the original mod, as we've come to the decision that there are a number of tracks that aren't very accurate or are out of place and feels very "unpolished" and messy. What we actually need to know, is how to change this music, to our updated versions.. Do the maps have a specific "load/play" line, within them (in GTKRadiant/Blender or whatever program it is) that tells the map or cut-scene to trigger a certain music track? @@Asgarath83 mentioned about using the dms.dat file from the base game for this type of thing. However, the original mod doesn't include or use any "dms.dat" file, but the specified music still plays on the specific cut-scenes or levels that it's attached to. So I was wondering what methods will work, for changing and editing the music into cut-scenes and maps and such.. @@GPChannel @@Asgarath83 @@therfiles @@ensiform @@RJA @@Fighter @Circa Can anyone offer assistance with this? Thanks
  10. Hello, would someone know why does my map get the portals error? There isn't anything specific that I did in the map, simply normal mapping as usual and doesn't happen on other maps. It's a problem because it drains FPS so badly and the error prevents my portals from dividing the map rooms. ************ ERROR ************LoadPortals: couldn't read D:\Program Files\Steam\steamapps\common\Jedi Academy\GameData\base\maps\project1.prt I googled it but found no help about it.
  11. Hi, I converted this Star Wars Battlefront (2004) map to MD3: https://staticdelivery.nexusmods.com/mods/795/images/116385_3.jpg at the moment this is the result (it haven't textures) : https://drive.google.com/file/d/0B5i8RkaXdKiLRmFqd2Nkajh1aDA/view?usp=sharing My project is port this map to Jedi Academy I have two questions: How import this to GTKradiant 1.4? Do you think that is possible port a battlefront map?
  12. So this is most likely a dumb question, but is it possible to populate a multiplayer map (because there are so many good ones) with single player NPC's? I would love to load up a multiplayer map in singleplayer because they are so much fun, but I haven't found out how. If anyone could help, it would be greatly appreciated.
  13. Hello everyone, just a quick note is that I have never used the func_train function before, so I could be absolutely doing something wrong. In this picture you can see how I have a brush that is as func_train, it's origin, and a path_corner where should the func_train go at: These are the func_train Keys and Values that I have used for the brush and it's origin: While it all looks good for me here in radiant, when I go in-game, the func_train brush appears close to my player spawn point and it's not moving, it's just there staying still, and when I go to the room where this func_train brush is actually located, it's not there, totally dissapeared. Could anyone please advise me how to do this correctly? I watched some tutorials but I can't seem to get the hang of it.
  14. Sorry if someones already asked this question and I didn't see it but I'm making a map and every time I load up the map I have no force power. And I don't mean it starts at zero and fills up to 100 I mean there's nothing there. Anyone know what I'm missing?
  15. Hello! I recently realized my Radiant is improperly fitting my textures. Whether I use the surface inspector and "fit" them or just apply them with their default settings, they come out slightly off. Not a huge problem for textures that repeat, but pretty noticeable for those that do. I tried googling for this, but am coming up empty. Has anyone ever encountered this or have any recs? I'm running gtk 1.4 on Windows 8.1, if that helps. Here's an image of what I mean--I used the default 'shader not found' so you can see the checkerboard just barely starting to repeat at the top and right edges.
  16. I have a pretty basic scripted elevator set up, so that it will move from a ref_tag at the bottom to a ref_tag at the top and back when activated. My script seems to work fine; I can see it execute properly in the console with developer mode on. However, no matter what I seem to do, I'm getting the message ERROR: Unable to find tag "elv_up" for ent 40! ERROR: Unable to find tag "elv_dn" for ent 40! (ent 40 is identified as my elevator) It then defaults the coordinate locations to (0,0,0) and my elevator moves to the world origin. Any ideas? EDIT Never mind, I was just being stupid and not triple-checking my entity names!
  17. Hello, as the title itself says, when I place a brush, give it any texture, even 'trigger' texture, I make that brush trigger_hurt and it dissapears instantly. I've tried making that brush with other trigger_ , but the same thing happens. Any tips or help is appreciated!
  18. I'm totally noob with these things and I need help. Map has 1280 brushes and 424 entities(lights, models, effects, items). Layout is simple, it's actually cube. Sometimes I have under 90 FPS when I have capped 125 FPS on almost every other map. Pls halp.
  19. I have a .blend model I need for make a project in JA but it isn't a valid model for exporting and I don't have a big experience in modelling. Someone can say if I can connvert and how can I make valid for .glm exporting this model here: https://mega.nz/#!UUwQiBib!nFQEgSoO0yygDY4kS704JUDYP-7v8dWfgmCiPDll3To ?
  20. Alrighty people, I've had a texture problem someday just now, but now that it's solved, another problem kicked in. See, I was compiling my map with only BSP -meta just to see if the brushes in the map are working correctly and stuff. When I tried to compile it as (Test) BSP -meta -vis -light -fast -filter, the compiling progress was stuck on PassagePortalFlow and it compiles more then half an hour, see the picture yourself : I found another topic that had same issue as me ( https://jkhub.org/topic/2492-compile-taking-ages/ ), but someone else had found the error for him apparently and he got it fixed. Would any of you expert mappers care to do the same for me? I worked my ass off on this map, I wouldn't want it to go to waste... I've already lost a few hours trying to fix it.
  21. Hello, so I have included some textures into my GtkRadiant, which works because I have set the correct dimensions of picture of that texture. Anyways, this seems strange, I have made the texture FIT on a brush in Radiant: But, when I go check it out in-game I get this shape: Any help? I really did my best by trying to solve it...
  22. So i've recently started my adventure with mapping, i'm currently working on a little map for the clan i'm in and i am having a very strange problem that i could not find any information about. I searched through this forum, searched through google and it turns out nobody knows nothing or nobody's encountered this before, ooor i'm just doing something wrong and making a fool out of myself right now. Anyway, here's what i struggle with: I created a small underground area that's supposed to have switchable lights so that it can get more moody with a press of a button. Radiant 1.4 has no problems compiling the map until i try to point a trigger to a light. The moment i do that the map turns out fullbright. Here's what the error in the cmd looks like: If i delete any of the target/targetname keys, the problem disappears, but that leads me nowhere because i really want those switchable lights. At first i thought i have too many lights placed close to each other but then i just deleted the trigger and it worked like a charm (and i also learned that it shouldn't really matter how many lights i've placed, i'm still new to the whole mapping things, excuse me ) Another screenshot with a proof of (i think) correctly made button. The button's indeed a func_button, and it's target is light1. Radiant's running with admin privileges, operating on Win10. Any ideas what might be the problem? P.S. Excuse my poor english, haven't slept yet.
  23. Hello! Shifting a few settings to make a night-time variant and I've noticed that the models/map_objects/yavin/yportal.md3 is still obnoxiously bright. I tried placing a negative light in there, but that doesn't appear to make a difference. Is there any way I can reduce the brightness on this?
  24. Hey, everyone! I've a few questions but some context always helps, so let me explain what I want to create! For the the single player level I am currently working on, I would like the player to have the option to spar with up to five other students positioned around the arena. While you're not sparring, I'd like for two random NPCs to put on a display of swordsmanship. I made two friendly NPCs and gave them a command to attack one another, and they obeyed. But without any more specific directions, it turned into the pair of them just kicking each other over constantly. They would also have a tendency to wander into one corner of the arena and stay there, or drift apart to the point they just looked at one another. I assume waypoints are a key thing here, but I don't completely understand how they work, so some advice in that area would be helpful. The second problem I'm having is with a pair of students who I simply wanted to behave as if they were talking to one another, moving through the different talk animations one after the other. I've done a lot of edits to that script, but the most recent one is below: Every time I update this, something different happens. Most recently, one just wound up jogging on the spot, which'd look great if I was planning to put Wii Fit on a tele infront of her of course, but that might be a tad inappropriate for the setting! Another question down the line is going to be about how to appropriately spawn all of the characters around the map. For instance, Luke is in the main hall. I could set him to spawn when the door is triggered and then despawn the next time, but then you could trick it. Correct me if I'm wrong, but the "if" statement would be the appropriate thing to use here? If anyone with the capacity to help me out could drop a line here, it would be greatly appreciated! EDIT: One of course realises AFTER creating his topic that there is, of course, a forum marked as "Coding & Scripting" so if you feel obliged to relocate this, I'll understand!
  25. Hey there jkhub! So recently I've taken on a project to make an entity mod for t2_trip and I've been told all of my changes would require nothing else but entity modding. Now, I'm only familiar with GTKRadiant mapping, so I went on and looked through some entity modding tutorials, which are not very widely spread on the internet. My plans for the mod: Reposition the info_player_start. Place some vehicle spawners around the map. (optional) Retexture some of the caulked areas as they will be accessible in MP, but were inaccessible in SP. Remove all of the SP entities, such as NPC_spawner's and triggers for them, scripts, trigger_hurt's and so on. Now, the first point doesn't look really hard, it's all about calculating the right origin for the place. The fourth point is probably the easiest one. However, the second one is a lot harder. I imagine that I can place some kind of model at a specific origin so it would look like a switch and place 2 triggers, 1 around it and 1 at a desired spawn location, but then the switch itself would not be solid. So I wanted to ask you guys if there's a way to make it solid (well, afaik, it would require a solid brush to be built around the model) or an another way to make a spawner. Finally, I have absolutely no idea on how to get the 3rd point done. A completely another way of making such a mod is doing all of this stuff in GTK, which would make it a lot easier, but, on the other hand, I'd have to refit all the textures and place all of the light entities again by trial and error. Plus all of the players would have to DL the plugin. So I'm really not up to this path. All in all, a helping from your side will be much appreciated P.S. Additional info can be found here.
×
×
  • Create New...