Jump to content

plugin-ffa3 crashes clients

Recommended Posts

Hey Jkhub!


I've started working on a custom ffa3, not a serverside entity mod but more of a clientside-plugin kind of thing, removing the invisible walls and stuff


It worked for the past few days, now on the latest update where i added a new room behind a wall, my non-openJK using clients get an error message as stated in the picture below.



Already tried removing the transporter.md3 from the main area, which i didnt really intend to do because I wanted to have non-plugin, vanilla players to have no affect on the main area (i.e. the known glitching through walls that are not physical on the serverside.)

Also tried to remap the shader using the technique given in the post about entmodding


Still this pretty much seems to be a compiler issue.

Yet it works for me playing with openJK and JA++


It all worked well for non OpenJK clients until i added this:








////// EDIT ///////

i attempted to start the map without any light compilation on a vanilla jk3 too, giving me following lines resulting in the same error as stated above:

]\devmap mp/ffa3
------ Server Initialization ------
Server: mp/ffa3
----- FS_Startup -----
Current search path:
C:\Program Files (x86)\LucasArts\SwJa Vanilla\GameData\base\lgnd_ffa3PlugIn.pk3 (20 files)
C:\Program Files (x86)\LucasArts\SwJa Vanilla\GameData\base\assets2.pk3 (62 files)
C:\Program Files (x86)\LucasArts\SwJa Vanilla\GameData\base\assets1.pk3 (8320 files)
C:\Program Files (x86)\LucasArts\SwJa Vanilla\GameData\base\assets0.pk3 (15346 files)
C:\Program Files (x86)\LucasArts\SwJa Vanilla\GameData/base

47496 files in pk3 files
Loading dll file jampgame.
------- Game Initialization -------
gamename: basejk
gamedate: Jul 22 2003
Loading dll file ui.
Loading dll file cgame.
Shutting down OpenGL subsystem
Requested feature was omitted at compile time

So it's not the lightmap that's the issue. Must be something i fucked up during compiling... but i compiled it several times with different settings

that compilation was merely the bsp -meta.

Edited by chewbuntu
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...